Can't copy files from my external hard drive

Discussion in 'macOS' started by Simont83, Feb 28, 2014.

  1. Simont83 macrumors newbie

    Joined:
    Feb 28, 2014
    #1
    I'm trying to copy a video file from my external hard drive to my Mac air. Every time I try I get:

    The Finder can’t complete the operation because some data in “07 36 Hours.m4v” can’t be read or written.
    (Error code -36)

    I've tried moving other files, some copy across others don't. there doesn't seem to be any thing that differentiates them.

    The video files that don't copy across don't seem corrupted. I can play them from my external hard drive.

    I've tried repairing permissions on the external drive, no effect.

    Has anyone experienced anything like this and know whats going wrong?

    Thanks
    Simon
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    It could be a corrupted directory on the external drive.
    It could also be corrupted (individual) files.
    It could even be a failing external drive.

    Have you tried running Disk Utility's "repair" function on the external drive?
    This is different than "repair permissions" -- it's trying to fix the directory of the drive itself.

    There is an excellent app out there called "Disk Warrior" that is designed to repair and rebuild directories on Mac drives. That's the program's only function, but it excels at that job.

    Hmmm BEFORE you do anything else....

    You say you can play the video files (even though you can't "copy" them).

    Try this:
    (Note, you will have to repeat for EVERY file that won't copy)
    - Open the file from the external drive
    - If it plays properly, do you have the "Save As" option in the menu?
    - If you have this option, try saving the file to your GOOD (internal?) drive.
    Does this work?
    (remember that when you "open" a file, it loads into memory. If the app can load the entire file into RAM and VM, perhaps it can then be saved to a different location)
     
  3. Simont83 thread starter macrumors newbie

    Joined:
    Feb 28, 2014
    #3
    thanks for advice.

    I've tried:

    running Disk Utility repair function, no change.
    Tried opening the file and doing a save as, no change.
    got disk warrior and rebuilt the directory, no change.

    This thing just refuses to be copied to anything.

    Maybe failing hardware??
     
  4. toriabelle macrumors newbie

    Joined:
    Jul 21, 2014
    #4
    Any luck?

    Hello there,

    I'm facing exactly the same problem. Did you find a solution?
     
  5. lt669 macrumors newbie

    Joined:
    Aug 21, 2014
    #5
    This same thing happened to me when trying to transfer files form my external hard drive to another external hard drive connected to our home network.

    However I found that I can transfer the data from the hard drive to my mac just fine. So with the data now on my Mac, I tried transferring the data to the hard drive connected to the network again, but this time straight from my mac but the same error showed.

    So it looks like it's not necessarily the hard drive, though that might have been the thing that corrupted the data.

    Just to clarify there is nothing wrong with any of the data, I simply cant transfer it across the network.
     

Share This Page