Can't copy files from my Mac Mini

Discussion in 'OS X Mountain Lion (10.8)' started by MVallee, Oct 1, 2012.

  1. MVallee, Oct 1, 2012
    Last edited: Oct 1, 2012

    MVallee macrumors 6502a


    Feb 8, 2007
    Ontario, Canada
    I have a 2011 Mac Mini hooked to my TV as a HTPC. Runs fine, never had any issues. I have Transmission running and when the files are done, I copy them over to an external drive. Been doing this for about a year with no issues.

    Today I went to copy over 3 files (total size 1.01GB) and it stopped at 8mb, then jumped to 16mb after about a minute, then finder stops responding and I have to re-launch, or power off. I thought it was the drive, so I unplugged it and tried transferring some files from my MacBook, they worked fine. Also tried going from my Mini to a different external drive and got the same issue. Tried copying and pasting from the folder to the desktop, same issue. Keeps hanging after a few seconds the freezes. I decided to upgrade to Mountain Lion (was on Lion before), and the issue remains the same. I have reset the PRAM, repaired permissions, tried copying files over ethernet, nothing. I've tried different files too and they all hang after a few seconds.

    Is there a problem with the internal hard drive? Any ideas whats causing this? Accessing the files seems to be no problem. Opened a video in Quicktime and it ran fine. Please help!

    [Update] - Tried creating a new user and copying a file there, did not work. Also tried using the terminal command "cp" to copy a file, still no luck. It seems to hang at the same place every time.

    [Update 2] - So I tried Carbon Copy Cloner, and it was no help. Transferred just as slow and kept hanging and freezing. So I found an external drive, formatted it, partitioned it and created a bootable partition of Mountain Lion. I booted into that on my Mac Mini and tried to copy the files. Same problem! It even hangs in the exact same spot 25.2MB. I am out of ideas. Please someone help!
  2. palace1000 macrumors newbie

    Mar 2, 2013
    Did you ever solve this, as I have a similar problem with an Seagate external drive which is joined up to a Mac Mini ?
  3. helios16v macrumors regular

    Nov 1, 2008
    I've had this problem with my HTPC too runing Ubuntu 12.04. All files come from my iMac with Mountain Lion and I've tried transfering onto an external, over ethernet via FTP, and even tried a USB stick with no avail. It ended up just being the file not capible of being copied. The file was set to have only permissions for my user only so if I tried to copy it or transfer it, it would start, then quickly fail and not tell me anything, it would just close.

    To fix this I had to click the file and hit Command i or you can right click and go to Get Info, at the bottom there is a little lock icon, click it and enter your password then you can change the permission settings from read only to read & write then lock the file again by clicking that little lock icon and you should be ready to go. This happens quite a bit with torrents as the providers lock their files so others can't reupload it as their own file, it's a kind of torrent protection method but flawed when you're on a Mac.

    Hope this helps, it's what's worked for me many times before when things won't copy or just suddenly stop copying and it's always ended up being the permission settings.

    Oh and if you're trying to transfer a folder full of files, do the same thing as I said before but before you click the lock icon to relock it, click the little square box with a gear on it and click "Apply to enclosed items" and it'll save the same permissions to every file in that folder just incase there are some other locked files.

    Best of luck

Share This Page