Can't copy stuff from external exFAT HDD

Discussion in 'macOS' started by MacRaccoon, Jul 27, 2013.

  1. MacRaccoon macrumors member

    Joined:
    Feb 12, 2013
    #1
    I have external HDD formatted in exFAT on which i have files copied from my windows 7 desktop.

    In the middle of copying them to my macbook pro I get an error saying "The operation can't be completed becasue you don't have permission to access some of the items"
    It stops and even the already copied files disappear.
    We are talking about 50gb folder with all kinds of files.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Tried copying the sub-folders one by one first to see, where the permission problem lies?
    Have ou opened GET INFO via selecting the parent folder (the one you want to copy) and pressing CMD+OPTION/Alt+I (to have a dynamic GET INFO window) and selecting the child folders in that parent folder to see, what SHARING & PERMISSIONS has to say?
     
  3. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #3
    the first sub-level of child folder doesn't seem to be locked, but there are 100s of folders below them, so im currently trying to copy the first level sub-folders one by one to narrow down the problem.

    But i was hoping for some kind of general solution, for example mass resetting of the permissions so i can copy all the files or something like that.
     
  4. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #4
    well 2 of the first level sub-folders can't be copied but they have way too many sub-folder to analyze them one by one.
    Isn't there a way to just fix the permission or change them all.

    After all I'm copying files from windows to external hdd to mac so don't really need any permissions kept anyway

    just to copy those files easily

    p.s.
    why it has to be so hard... huh
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    Kind of hard to help with the information given.

    One thing to try is select the top level directory of what you are trying to copy from, then CMD-I. At the bottom there should be set of permissions. Change those, the hopefully it will give an option to change permissions recursively. I really can't remember if it gives that option or not.

    The other thing is to use the command line. Are you comfortable using the command line? If so, let me know and I will try to help.
     
  6. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #6
    I'm total mac newbie, so I can use the command line but only with instructions :)
    anyway, i'll try the GUI solution you offer me first and will get back to you! :)
     
  7. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #7
    Under "Sharing & Permissions" it says "You can only read"

    and i don't see a way to change a permission

    but read should be enough in my case?
     
  8. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
  9. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #9
    Try using disk utility to repair permissions.

    The strange thing is exFat does not have permissions, so everything should show up as 777.

    If the repair permissions thing doesn't work, google with the search terms 'exfat osx permissions'. Folks that have had this issue have found some really strange fixes.
     
  10. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #10
    You could try this:

    Have the drive mounted on the desktop, with just the icon showing (no windows open)

    Click ONE TIME on the drive to select it

    Type "Command-i" to bring up the "get info" box

    Down at the bottom, is the "sharing and permissions" area. Make sure the "disclosure triangle" is clicked, showing details.

    At the lower right corner, there should be a "lock" icon. Click on it, then enter your administrative password.

    Now, on the lower left, there should be a checkbox for "ignore ownership on this volume". Put a checkmark into that box.

    Close the get info box.

    This works with Mac-formatted drives.
    I have no idea whether or not it will work with an "exFat" drive.

    If this doesn't work, I suggest that you:
    - Take the exFat drive back to the PC
    - Copy all the files from it to either another drive in "Fat32", or perhaps a USB Flashdrive in Fat32
    - It may take more than one pass to migrate the files over.
     
  11. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #11
    Sorry guys, the HDD is exFAT but there is a file container that's formatted in NTFS
    so when i mount it i see permission that i can only read, and the fix permission button in disk utility is grayed out (which is to be expected i guess)

    but still i can read ntfs, so why it can't copy?

    There are some files on that HDD that have been sent from MAC, could they have permissions that mess things up?
     
  12. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #12
    any ideas given the new information in the previous post?
     
  13. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #13
    OS X does not have the ability to write to NTFS partitions natively. You would have to get a third party NTFS package. My recommendation would be to get the drive formatted in exFAT without using the NTFS container if you can.
     
  14. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #14
    i just want to read from the NTFS
     
  15. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #15
    Using the terminal to copy files won't stop when it encounters a file/folder it can't open: it will just say it can't copy a file/folder, and goes to the next file.

    To copy directories, use cp -r.
     
  16. MacRaccoon thread starter macrumors member

    Joined:
    Feb 12, 2013
    #16
    that's actually a good idea!


    btw any idea why i can't read just some of the files?
    I suppose the problems are giving some osx files i have there that have been send from friends with macs before.
    Can I fix their permissions somehow?
     

Share This Page