can't copy stuff to USB external hard drive(FAT32)

Discussion in 'MacBook Air' started by watermelonbook, Apr 1, 2015.

  1. watermelonbook macrumors regular

    Joined:
    Jan 31, 2014
    #1
    I have a MBA 11.(late 2013)

    The USB external hard drive is made by Seagate and it has a 1TB capacity.
    The drive is in FAT32 format. It is a large 3.5 drive and requires AC power
    to run. It functions just fine when connected to a Windows PC,
    Playstation3, or even a Chromebook notebook. I can copy, paste, move,
    create new folders, or delete files.

    When the drive is connected to my MBA, I can only view the files.(play
    a video or audio file, for example) However, I cannot make modifications
    to the drive.(i.e. copying files from MBA to USB drive)

    I've been searching online for a solution but none has worked so far.
    Is there something that I'm doing wrong?

    The strange thing is that my MBA has no problem modifying files on my
    other portable drive(a small palm-sized USB 3.0 drive that has 1TB,
    also in FAT32, powered by the MBA's USB 3.0 port)
     
  2. Porco, Apr 1, 2015
    Last edited: Apr 2, 2015

    Porco macrumors 68030

    Porco

    Joined:
    Mar 28, 2005
    #2
    Have you tried doing 'Get Info' on the drive and expanding the 'Sharing & Permissions' section at the bottom of the Info window? Your username should have the privileges to both 'Read & Write'. If not, you can change it to that by clicking the padlock and entering your password to allow you to change it.

    EDIT: My bad, superwoman below is right, ignore this post, sorry.
     
  3. superwoman macrumors regular

    Joined:
    Apr 25, 2005
    Location:
    Monterey,CA
    #3
    Your observations are consistent with an NTFS-formatted drive. OSX's native NTFS driver only allows read, not write. Do you mind using Disk Utility to double-check the drive format?

    If it is indeed FAT32, then permissions has got nothing to do with it. FAT32 has no access control.
     
  4. watermelonbook thread starter macrumors regular

    Joined:
    Jan 31, 2014
    #4
    I'm not home right now, but I can say with 1000% certainty that the drive
    is FAT32. It spend most of the time connected via USB to my Sony
    Playstation 3 for playing video/audio files(MP3, AVI, MP4, etc). The PS3
    is incapable of reading NTFS format. :)
     
  5. ET iPhone Home, Apr 2, 2015
    Last edited: Apr 2, 2015

    ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #5
    You have to format the drive for both pc and apple use in Disk Utility. Backup all the files first and reformat:

    http://guides.macrumors.com/Formatting_an_External_Device

    The same happened to me. For some reason, I had to reformat to FAT32 on my MBA, not PC. Once it was reformatted, I used the drive on my MBA first before using it on my pc and it worked.
     

Share This Page