Can't copy to 4GB Transcend Flash Drive

Discussion in 'MacBook Air' started by weeediee, Mar 29, 2013.

  1. weeediee macrumors newbie

    Mar 29, 2013
    Hi, I bought a flash drive to copy files from my Macbook Air - 4GB Transcend USB 2.0 - and I can't copy anything to it at all. It comes up with Error Code -8062. It's formatted to MS-DOS(FAT) and I am using OS X Mountain Lion.
    Is the drive corrupted or something?
  2. B... macrumors 68000


    Mar 7, 2013
    Use Disk Utility to format it in another format for Macs.
  3. weeediee thread starter macrumors newbie

    Mar 29, 2013
    Thanks, but I've tried reformatting it to every other option besides MS-DOS (FAT), and nothing works!
    I know the flash drive works as I've just tried it with an old PC and could copy files to it easily, so it seems to be a problem with the mac. What else can I try other than reformatting? Do I perhaps have some permission issue with writing to an external drive? I can't seem to see any obvious problems...
  4. chadamorrill macrumors 6502

    Sep 13, 2007
    Orlando, FL
    Silly question... are you formatting at the top level? Or just the partition itself? When you format it to Mac, does it then not work on the PC? If it still works on the PC after formatting to MacOS (ext/jour), disk utility may not be working correctly.

    If you have a PC available, there's a series of dos formatting commands you can try. Let me know if you want them.

Share This Page