Can't deactivate "Automatically adjust brightness".

Discussion in 'MacBook Air' started by Tootles, Aug 16, 2011.

  1. Tootles macrumors member

    Joined:
    Jun 15, 2011
    #1
    In System Preferences, under display, I have "Automatically adjust brightness" unchecked, yet the display still seems to be automatically adjusting. I want it set on just 2 bars but I'll find it on 4 bars when I periodically check to see if it's still on 2.

    2011 MBA 11", i5/4GB/128GB
     
  2. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
  3. mixman macrumors member

    Joined:
    Aug 3, 2011
    #3
    Had the same problem. There's another checkbox for this, IIRC, under System Preferences > Energy Saver.
     
  4. Tootles thread starter macrumors member

    Joined:
    Jun 15, 2011
    #4
    You don't mean "Automatically reduce brightness before system goes to sleep", do you? That's something different from what I'm talking about.
     
  5. alecgold macrumors 6502a

    alecgold

    Joined:
    Oct 11, 2007
    Location:
    NLD
    #5
    had no problem disabling it.
    are you connected to an external display at that moment?
     
  6. Tootles thread starter macrumors member

    Joined:
    Jun 15, 2011
    #6
    Nope. I'm using the MBA as a laptop.

    Are you sure it's disabling for you? What MBA do you have?

    Even after the 10.7.1 update today, my 11" i5 with LG screen is still automatically adjusting the screen brightness, even though I have that feature unchecked in the Display preference.
     
  7. aryan118 macrumors regular

    Joined:
    Aug 10, 2011
  8. alecgold macrumors 6502a

    alecgold

    Joined:
    Oct 11, 2007
    Location:
    NLD
    #8
    I have the 11" i7, LG screen, samsung 256Gb. It worked with 10.7 and 10.7.1 as well. And it certainly is disabling as I got really annoyed by the constant varying light when i would have it on my belly while hanging in a hammock. (sun, no sun, sun, no sun on the sensor).

    The other day I had an odd thing with an old MBP. I couldn't adjust the sound, it was greyed out. I could change it in iTunes, but not in systemprefs. When I inserted a headphone it became black, and when I pulled it out, it stayed black. Odd bug.
    But perhaps when you plugin an adapter or external screen, wait a few seconds and then get it out, it might work again?!
     
  9. mixman macrumors member

    Joined:
    Aug 3, 2011
    #9
    http://forums.macrumors.com/showpost.php?p=13217311&postcount=5
    Unchecking the "Slightly dim the display while using this power source" (battery) fixed the automatic brightness alterations for me.
     

Share This Page