Can't delete all songs off my iPhone 4

Discussion in 'iPhone' started by andrewclarkdrum, Feb 18, 2014.

  1. andrewclarkdrum macrumors newbie

    Joined:
    Apr 9, 2013
    #1
    Hi there,

    Today I tried wiping all my music off my phone so I could have a fresh start at building my Music library again. On iTunes on my MacBook, I have my phone set for "Sync Music" and under that heading, "Selected playlists, artists, albums, and genres". Then I de-selected every playlist, artist, album, and genre, and deleted all the songs under "Manually Added Songs". When I press "Apply" and it goes through the whole Sync cycle, by the end magically some of the boxes have selected themselves again. I've done it over and over and I've even disabled iCloud, but I still have the same problem. Afterwards I can still play those songs on my phone too. How do I permanently delete all of those songs?

    Thank you.
    Andrew
     
  2. EM2013 macrumors 65816

    EM2013

    Joined:
    Sep 2, 2013
    #2
    Have you tried selecting 'manually manage music and videos' then deleting all the songs you want then hitting sync?
     
  3. andrewclarkdrum thread starter macrumors newbie

    Joined:
    Apr 9, 2013
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Navigate to your phone when it's connected. The tick box is bottom left hand side of the info screen. Remove the songs and hit sync.
     
  5. andrewclarkdrum thread starter macrumors newbie

    Joined:
    Apr 9, 2013
    #5
    Thanks to both of you for trying to help, but unfortunately it hasn't solved the issue. When I click on 'manually manage music and videos' and then I click on the 'music' tab and everything is greyed out - I'm unable to manage my music! So I can't do what EM2013 had suggested.

    What I tried to do was click on 'manually manage music and videos', then go to 'music' and click on the 'sync music' tick box. Then I would select/deselect the albums I want/didn't want. Then I would hit apply and wait for it to sync. Afterwards I would go back and notice that the 'manually manage music and videos' is no longer ticked. Most of the albums that I had tried to remove were back, and on my phone would be songs that were never selected in the first place. Again, I have iCloud disabled, so I have no idea what's going on. I've found Music, iTunes, and iCloud so much of a hassle.

    Are there other boxes under the same list as 'manually manage music and videos' that should or should not be ticked?

    Can you think of anything else that would help?

    Thanks.

    ----------

    Also, when I have Music open on my phone, some of the songs I don't want on there have the cloud symbol with a red arrow pointing down. Does that mean I have to stream them from iCloud to listen to them? Because if I have iCloud disabled then those songs shouldn't be able to play, but they do...
     
  6. EM2013 macrumors 65816

    EM2013

    Joined:
    Sep 2, 2013
    #6
    Sorry for the late reply. Click 'manually manage music and videos' then instead of clicking on the music tab, click where it says 'on this iphone' then click on music and highlight all the songs and hit delete, then hit sync. This should fix your issue.

    And on your iphone go to settings, scroll down to music, and deselect 'show all music'
     

Share This Page