Can't delete annoying system sounds

Discussion in 'OS X El Capitan (10.11)' started by soundsgoodtome, Jul 12, 2015.

  1. soundsgoodtome macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #1
    For a number of years, every time there's been an OS update, I've removed the extremely annoying "Volume Mount" sound at:

    /System/Library/Components/CoreAudio.component/Contents/SharedSupport/SystemSounds/system/Volume Mount.aif

    But when I attempt to delete that file in El Capitan, I get an error message: "The operation can't be deleted because the item "Volume Mount.aif" is locked. This was never a problem before.

    Things that didn't work:

    - Unlocking the file via the Get Info window. (Of course the numerous parent folders are also locked.)
    - Logging in as root.

    Honestly, I was confident that logging in as root would work, but it doesn't. Has Apple just locked down the system even further, this time? What must I now do to delete that frigging annoying sound?!?
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Rootless should be disabled from recovery partition.
    Another issue related to this rootless. :p
     
  3. soundsgoodtome thread starter macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #3
    I really appreciate the reply, but I don't understand. Can you please be more specific? :)
     
  4. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #4
    1.cmd+R to move to recovery environment.

    2. From utility menu, which you use to fire up terminal, select SIP. I cannot remember clearly, but that menu is new from el capitan, you should be able to notice it.

    3. Clear check of the only item on the dialogue window.

    Restart, and nuke the sound you hate dearly.

    Don't forget to reenable unless that sound is back.

    Enjoy. :p
     
  5. soundsgoodtome thread starter macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #5
    That did it! Thank you!!

    Exact steps, for anyone else reading:

    1. Restart, then hold down the ⌘ and R keys at startup to enter Recovery mode.
    2. In Recovery mode, ignore center window. Instead, from Utilities menu, select Security Configuration.
    3. Untick the checkbox next to Enforce System Integrity Protection, and apply.
    4. Restart, and nuke annoying sounds!

    (Note: When I reentered Recovery mode to reenable Enforce System Integrity Protection, the checkbox was already ticked. So, it seems the system automatically reenables it upon restarting.)
     
  6. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #6
    Thanks for your clarification.

    This should help quite a lot. :p
     

Share This Page