Can't Delete File From Desktop...

Discussion in 'Mac Apps and Mac App Store' started by funkenbooty, Oct 23, 2003.

  1. funkenbooty macrumors newbie

    Oct 16, 2003
    I have been trying to delete a file that was created by an aborted download with IExplorer.

    I have removed the file from the download manager but that did not do the trick, still can’t delete! What else can I do? Is there a safemode in OS X 10.2.7?

    This is the error message I get:
    The item “ “ is being used by another task right now (other tasks include moving, copying, or emptying the trash.) Try again when the other task is complete.
  2. caveman_uk Guest


    Feb 17, 2003
    Hitchin, Herts, UK
    You are trying to delete it by dragging the file to the trash yes? Sorry to ask but just checking.

    Log out and log back in and try. If that doesn't work try rebooting. Failing that you can use the terminal and force it.
  3. jonapete2001 macrumors regular

    Oct 20, 2003
    try using this app called force delete. It worked for me when i had that problem

    Force Delete
  4. funkenbooty thread starter macrumors newbie

    Oct 16, 2003
    I tried dragging it to Trash and rebooting. Deleted it's reference in the download manager in IE.

    Is there a good guide to using the command line for OS X somewhere? I am a little familiar with Linux and more familiar with DOS. NOT familiar with using terminal in OS X.
  5. funkenbooty thread starter macrumors newbie

    Oct 16, 2003
    Hey SilentPanda!
    Thank you so very much. Those instructions did the job. I am so happy to be rid of that file!!!!:D :D :D :D :D :D :D :D :D :D
  6. BigHairyBuds macrumors member

    Sep 30, 2003
    Whenever you have a file you cannot delete, log in as the Admin, select the file and choose Get Info. In the Get Info window open the Ownership & Permissions tab, unlock the lock and enter your Admin PW and switch the owner (typically from System) to your Admin Acct (it should have (me) in paranthesis). Toss that bad boy in the trash and say goodbye. Then spark a fat one to celebrate. Repeat as necessary :D.
  7. jelwell macrumors member

    Jan 31, 2003
    1. open terminal
    2. "cd Desktop"
    3. "rm -f"

    that should work. if it doesn't then you have real problems. i once had a file that when dragged to the trash caused a kernel panic! wowsa. rm just ignored it. I had to boot into single user mode to get rid of it. and lots of drive 10 checking helped restore my disk.

Share This Page