Can't delete file on external hard drive

Discussion in 'macOS' started by Vormech, Dec 8, 2007.

  1. Vormech macrumors newbie

    Vormech

    Joined:
    Nov 25, 2006
    Location:
    Columbus, Ohio
    #1
    I've had some trouble deleting a file off my external hard drive connected to my iMac. The file shows up on the mac side but doesn't appear when I switch over to windows. I've tried to uncheck the permissions of the locked file but it will not unlock it.

    When I try to send it to the trash, a dialogue appears saying that it is a locked file but do you want to delete it anyway. Nothing happens when I hit continue to delete the file. Anyone have any suggestions to get rid of this file?
     
  2. ntraft macrumors newbie

    Joined:
    Mar 3, 2008
    #2
    Same here

    Same problem here. Unfortunately I don't have a solution yet; just a bunch of things that SHOULD work, but DON'T.

    First off, I can't uncheck the "Locked" property in the "Info" window for any of the files. I also have the same phenomenon where it claims to delete the file and then silently ignores your plea. According to this article on Apple's knowledge base you're supposed to be able to move it to the trash anyway, and then you have to hold down the "Option" key while emptying the trash to get rid of locked files as well as normal files. Well, not from an external drive, guys. THANKS.

    Second, I can't simply delete the files using "rm" in Terminal. This is with or without root permissions. AND this is DESPITE the fact that all the files show full permissions when viewed with an "ls -al" (they show -rwxrwxrwx). Leopard is indifferent to my suffering.

    Also-- and here's the REAL kicker-- I can't even remove the uchg file flag that causes this whole nasty problem in the first place!! Not even as superuser!!! (the command I used was "sudo chflags nouchg /filename")

    I think I might have to do it from a Windows machine (the filesystem is FAT32, btw). There are a bunch of 3rd-party apps to deal with this heinous "feature," but if chflags doesn't work I'm going to go ahead and assume they aren't about to do any good.

    TAKE PITY ON ME, OS X!!
     
  3. Harpua macrumors newbie

    Joined:
    Apr 24, 2008
    #3
    Same problem here.

    i recently converted from pc to mac, and have my entire music collection on an external drive. I formatted the disc that they're all sitting on now in Mac OS Extended (Journaled) format, but upon copying files back to this disk, some are locked, others aren't. ?!?!?

    anyone got a solution?
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    this happend on my FAT32 USB stick.

    try typing these commands into Terminal. replace "disk" with the name of your external drive.

    Code:
    cd /Volumes/[I]disk[/I]
    Code:
    sudo rm -rf .Trashes
    it will ask you for your password and may show a warning. you wont be able to see your password being typed for extra security so just type it and press enter.

    Code:
    killall Finder
    then trash a file from the external drive and try to empty the Trash.
     
  5. nikola.prague macrumors newbie

    Joined:
    Dec 30, 2011
    #5
    Virtual is simple solution

    If you use Windows in Parallels which are running all the time. Just connect the disk to windows and it will be automatically mounted to your MAC OSX. In this connection, no troubles with NTSF arise.
     
  6. bobbytomorow macrumors 6502

    bobbytomorow

    Joined:
    Nov 10, 2007
    Location:
    Left Coast
    #6
    This worked for me, thank you :)
     

Share This Page