Can't delete file on External Hardrive

Discussion in 'macOS' started by xanish, Sep 17, 2009.

  1. xanish macrumors newbie

    Joined:
    Sep 16, 2009
    #1
    Hi,

    So, I'm have a problem...

    I lent my brother my external hard drive to copy some files on to his computer (which I have done before) and when he gave it back, it had some random files on it. At first I didn't give it much thought, because since he uses Windows, that happens sometimes. But I've always been able to just delete the files.

    But this time there is a folder that simply will not delete, and I haven't been able to do anything to change it. I deleted the files inside the folder successfully.

    I tried renaming the file and it said that I did not have sufficient privileges. But I'm the only person that uses my computer, there are no other accounts...

    I downloaded Batchmod, but no matter what I did, it made no difference to how the folder responded.

    Any ideas?


    P.S. In case it helps, the folder is called RECYCLER. I thought it could be virus for a while, but I ran a scan on iAntiVirus and nothing was detected.
     
  2. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #2
    Are you sure it's not formatted as NTFS? Just reformat it in Disk Utility.

    S-
     

Share This Page