Can't delete files from external hard drive

Discussion in 'MacBook Pro' started by brlebu, Mar 25, 2008.

  1. brlebu macrumors newbie

    Joined:
    Mar 25, 2008
    #1
    I have a 2.4 ghz MacBook Pro and I'm trying to clear an external hard drive of files from another computer.

    I was able to delete everything aside from a couple of locked music folders. When I look at the info for these folders, I'm unable to unlock them. Also, I am the admin on this computer (in fact, my account is the only account on the computer) but for some reason, in Sharing and Permissions, it says "You can only read" and I'm unable to change that. Nothing else even shows up in the S&P section of the info window.

    I've tried a few different commands in terminal (that I found on a few different Mac forums) to delete these files, but none of them worked.

    Also, when I try to drag the folders out of the trash to see if I can change the Permissions, they just copy to the desktop instead of actually moving.

    And I tried logging in as root user, but I didn't have permission to delete there either.

    I have no idea what computer these files originally came from, so hopefully I don't have to go back to the original computer to delete them...

    Any suggestions would be much appreciated.

    Thanks a lot -

    blb
     
  2. scr1968 macrumors regular

    Joined:
    Sep 4, 2007
    #2
    I bet this is a drive from a Windows PC that is formatted as NTFS. Mac's can read those drives but can't write to them.

    SCR
     
  3. deadpixels macrumors 6502a

    deadpixels

    Joined:
    Oct 30, 2006
    #3
    if you want to delete everything from the external HD, why don't you just format it?? otherwise holding the Option key when deleting locked stuff might help.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    Go to the drive on your desktop and hit Ctrl-Command-I and it should say in "Format" under General what the file system is.

    If it says Mac OS Extended, go to the bottom and click the lock to reset permissions.

    If it says Windows NT System, you need a driver like MacFuse (free) or Paragon NTFS (paid) and it will allow you to write to the drive.
    MacFuse you will need to compile it yourself and stuff, so if you don't know how to do that don't use it. Paragon is just a easy installer (and uninstaller).
     
  5. wk127001 macrumors member

    Joined:
    Feb 24, 2008
    #5
    you could try: chmod 777 <target_file_name>

    then use: rm <target_file_name>

    if you need root access you can type: sudo -i

    This is all from the terminal by the way.

    EDIT: since its a folder you actually have to use: rm -R <target_folder_name>
     
  6. brlebu thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #6
    Thanks for the responses.

    As soon as I posted this thread, I realized I should just format the drive, so that's what I did. Problem solved.

    Thanks again.
     
  7. I WAS the one macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #7
    is not solved. I have a problem similar and I don't want to format the drive. The re are two files on my trash that aren't on the drive either or my Mac. They are still there and everytime I delete or empty the trash folder says it can be deleted because thouse files are in used. I DO NOT HAVE THOUSE FILES NO MORE. why it showing up in the trash ?? how I get rid of them?? help
     
  8. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #8
    You can't empty the Trash or move a file to the Trash and Solving Trash Problems
     
  9. I WAS the one macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #9
  10. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #10
    Ah, sorry my omniscience is not THAT omniscient as it seems.

    Does it also happen in another, even temporarily created, user account? Make sure to log out of your current account. Do you have access to any other Mac?
    Just to make sure, the external HDD is formatted with "Mac OS Extended"?

    Yeah, I know, I should know that, but I am flat out of west wings. Ask CJ.
     
  11. microsnook macrumors newbie

    Joined:
    Sep 2, 2012
    #11
    plug the drive in and open disk utility and erase it but use the mac OS extended settings!
     
  12. I WAS the one macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #12
    Yes. Done. Yes. YES.
    IT STILL DOESNT WORK. There's must be a solution for this other than erased the external drive. I don't want to erase it

    ----------

    It is already in Mac OS ext.

    I DON'T WANT TO ERASE IT. That would be the best thing to do if I wont care of the content.
     

Share This Page