Cant delete files from external SSD

orcasound123

macrumors newbie
Original poster
Nov 16, 2018
3
0
Ive been demoing Devonthink - and for whatever reason its been giving me a fit - Ive been keeping its folders on an external 1TB Drive SSD - It looks as if it pegged out my memory on that G Drive - and now the drive only has 73mb remaining. - Problem is - when I go to delete from the external - the trash icon is grayed out - - and when I went to doc utility. - I get this error - IS the issue - the drive being too full - or by chance - is the drive starting die - Use had no issues with the drive until Devonthink came into view. - Is there an app that will allow me access to the SSD - and allow me to delete files - I have Techtool pro - which has this feature - But it states that I don't have permission to delete from this drive.

More than likely due to the fact that the system is throwing up the error.

Any help would be greatly appreciated.
 

Attachments


Fishrrman

macrumors P6
Feb 20, 2009
17,182
5,536
"I have Techtool pro - which has this feature - But it states that I don't have permission to delete from this drive."

First suggestion:
1. Mount the problem drive on the desktop, so that its icon is showing
2. Click ONE TIME on the icon to select it
3. Type "command-i" (eye) to bring up the get info
4. At the bottom of get info, there is a lock icon. Click it and enter your password
5. In "sharing and permissions", there is a checkbox "ignore ownership on this volume". Put a check into it.
6. Close get info.

Try TechTool now.
Any changes?

Second suggestion:
DON'T try to delete too many files at once, there may not be "space enough" to do this (I think the files have to get copied to the "trash" folder, and there may not be enough room left).

Instead, try to delete JUST ONE OR TWO SMALL FILES first.
Does that work?
Make sure that if they go to the trash, that you EMPTY the trash.
Then, delete one or two more small files, and empty the trash.
Does this work?
If it does, keep doing that for a while.

YES, I know it's going to be tedious.
But sometimes you have to do, what you have to do in order "to get some breathing room back".
 

orcasound123

macrumors newbie
Original poster
Nov 16, 2018
3
0
Thanks so much for your quick reply.

First suggestion- I already checked that - the box was checked to begin with.
Second suggestion - IU can't even delete the smallest of files as the trash icon is grayed out on that particular drive.
 

chown33

Moderator
Staff member
Aug 9, 2009
8,362
4,346
Pumpkindale
I suggest that you follow the advice in the screenshot you posted, and copy any data you want to keep to another drive. Once you've done that, and verified the data is valid (open it in the appropriate app), you can then use Disk Utility to Erase the drive.


The reason you can't delete is the disk is corrupted. It it weren't corrupted, then Disk Utility wouldn't need to rebuild the catalog B-tree (per message in screenshot) How it got corrupted is anyone's guess. It may be related to DevonThink, or it may just be a coincidence.

It's almost a certainty that the OS is detecting the corruption and mounting the disk read-only. If it's mounted read-only, then you can't delete, rename, move, save, or create anything on that disk.

If you want to confirm it's read-only, paste the following command into a Terminal window, then press the RETURN or ENTER key on your keyboard.

Code:
mount
The output should show a list of attributes and other identifying info for each mounted disk, volume, or partition. If your disk is listed as read-only, then that's the answer. If it's not read-only, then drag-select the entire output in the Terminal window, then copy and paste it into a post here.
 

orcasound123

macrumors newbie
Original poster
Nov 16, 2018
3
0
Chown33- thanks for the reply - that is my intention - I also tried to use the terminal to delete a folder off of the that drive - ... it was using the "Rm and the path of the file" - I did that. - and boom my Mac went nuts - I tried shutting it down, ended up powering off - when I rebooted - I had to enter the iCloud info again - and most of FCPX plugins were missing, and most of my Library contents for certain apps - its been a bad week
 

Velin

macrumors 65816
Jul 23, 2008
1,471
909
Hearst Castle
Don't give up on Devonthink. It is an amazing database application. Do a test on a small dataset, you'll see how powerful it is. Pretty amazing what it can do simply by doing an import on any folders/files you throw at it -- and it can handle every single file type, including metadata. Devonthink gets it all. It's the Wolfram Alpha for the pro user and her/his desktop.