Can't delete files from leopard

Discussion in 'macOS' started by mycomputerhates, Apr 10, 2008.

  1. mycomputerhates macrumors newbie

    Joined:
    Apr 10, 2008
    #1
    Hi,

    I have a G5 that I just updated to Leopard from 10.3.9

    After updating to Leopard, everything seemed fine, but my eject button on my keyboard will not function and I cannot seem to delete ANY files from my computer. Right clicking and selecting move to trash accomplishes nothing.

    When I try to drag a file to the trash, it does nothing. When I try for a second time, a window appears saying perparing move to "Trash" with a timebar, but nothing ever happens beyond that. It just sits there and the item won't move to the trash.

    It won't even let me close the window. Eventually I have to restart finder just to close the "preparing" window, but the file still remains.

    This is very frustrating. Anyone have an ideas or suggestions about what to do now?

    :mad::mad::mad::mad::mad:
     
  2. lostinspace2011 macrumors member

    Joined:
    Apr 9, 2008
    #2
    Repair Prermissions

    You might want to try to boot off your install CD. At the installations menu select Disk Utilities under the Tools menu, and then repair disk permissions.

    I am not 100% sure about the names of the menu items, but I am sure you'll figure it out.

    Otherwise have a look in the console for any obvious error messages.

    have fun
    Alex
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    the eject button now has a delay. hold it for a few seconds or press "option+eject" for instant eject.

    & then try typing these commands into Terminal. the first deletes the Trash directory and the second relaunches Finder to recreate the Trash directory.

    Code:
    sudo rm -rf .Trashes
    Code:
    killall Finder
     
  4. mycomputerhates thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #4
    I tried to verify the disk, but the bar never moved and I had to go to work. But I'll have to try those other options and see what happens.

    Thanks for the ideas
     
  5. mycomputerhates thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #5
    I tried using Terminal and entering the sudo code, but when I do a warning comes up:

    "WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort."

    At this point it won't let me type anything else and Ctrl-C just restarts the whole process. When I type in killall Finder, finder relaunches, but the problem continues with me not being able to delete anything.

    Later I ran disk utility from the computer and ran "verify disk permissions". It took a long time and when it was done, it said verification complete, but nothing else. I've never run disk utility before. Should I click repair disk permissions next?
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    it doesnt show a typing input so it is super secure. when it asks for a password just type it and press enter… nothing more, nothing less.
     
  7. mycomputerhates thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #7
    no such luck

    Neither of these options have appeared to work so far.

    I tried entering the codes in Terminal and the only effect it seems to have is restarting Finder, yet I still cannot delete items.

    Verify/Repair disk also seemed to work to no avail.

    Oddly enough, however, I have external harddrives and I am able to delete items from them, but those items just sit in the trash can. When I try to open the trashcan, the pinwheel appears and I have to restart Finder because it locks up.

    So far, am I the only one to have encountered this majorly effed up problem?
     
  8. NikTheGreek macrumors newbie

    Joined:
    May 30, 2009
    #8
    have you been able to solve your problem in hte meantime?

    I have a similar problem ... I had copied files generated under windows to my Mac hard drive. I can copy and open the files, but not move or delete them! I have also tried the Terminal command "sudo rm -f" ... without success
     

Share This Page