Can't delete from system drive without password

Discussion in 'OS X Mountain Lion (10.8)' started by Ryan Drean, Jun 5, 2015.

  1. Ryan Drean macrumors newbie

    Joined:
    Jun 5, 2015
    #1
    I am not really sure what I did to make this suddenly start. The only thing I did was upgrade the RAM which certainly might have been a factor I just don't know if this could cause this.
    I am on 10.8.5. Mac Pro 2009. 4,1.
    Just out of the blue when I go to delete any file in any folder on the main OS HD it forces me to re-enter my password. I am an admin (the only admin). I have verified and then repaired permissions on this drive.
    Any ideas how to stop this?
    If I hit delete in the menu bar I just want it to delete (move to trash)

    Thanks!
     
  2. Ryan Drean thread starter macrumors newbie

    Joined:
    Jun 5, 2015
    #2
    Answer: Well I don't know if I did do something that messed this up without knowing but I might have fixed it by accident. This is what fixed it for me:

    Go to Info for the main Mac HD

    Click your User Name (Assume it also has to be the admin but not sure)

    click the little gear down low next to + and -

    Hit "Apply to Enclosed Items..."

    It runs. That seems to have fixed my issue.
     
  3. e93to macrumors 6502a

    e93to

    Joined:
    Jan 23, 2015
    Location:
    Toronto
    #3
    This happened to me awhile ago... I did nothing to the computer at all, but suddenly I was asked to enter password for deleting files, etc. And yeah, "apply to enclosed items" fixed it.

    I always wonder what would cause such thing...
     

Share This Page