Can't delete Guest User on log in menu

JPage

macrumors newbie
Original poster
Nov 9, 2013
15
0
Hi folks! Today, I turned on my Macbook Pro 15'' Late 13 and it showed Guest user on log in menu. I disabled on System Preferences and unchecked "allows guest to log in this computer" and then I locked the pad. Nothing happened. Guest account keeps showing on Log in menu.
I even disabled Find my Mac, logged out iCloud account and then restarted and the result was the same.
Do you have any idea?
 

AlteMac

macrumors regular
Jul 21, 2011
115
12
New York suburb
I believe that if you have Find My Mac activated, it requires a guest account. When the finder of the Mac opnes up as a guest user it logins in, and that gives you the ability to wipe it out or send a message, etc.
 

JPage

macrumors newbie
Original poster
Nov 9, 2013
15
0
So, are you telling me that it's a mechanism from Apple to locate your Mac in case of loss or theft? I find it really annoying having a guest user account since I'm the only person who uses the mac. Besides, my mac never leaves home, so for me it's not useful.
 

AlteMac

macrumors regular
Jul 21, 2011
115
12
New York suburb
So, are you telling me that it's a mechanism from Apple to locate your Mac in case of loss or theft? I find it really annoying having a guest user account since I'm the only person who uses the mac. Besides, my mac never leaves home, so for me it's not useful.
Yes, that is exactly what it is. I have Find My Mac turned off on my MacPro and turned on on my MBA, which does leave the house. This is not a new feature. Go to your iCloud settings and disable it if you don't want it. I think you will then not see "Guest" when you boot up.
 

JPage

macrumors newbie
Original poster
Nov 9, 2013
15
0
I tried that before with no success. El Capitan was an awful update, I guess :/
 

AlteMac

macrumors regular
Jul 21, 2011
115
12
New York suburb
I turned it off and do not get a Guest user choice when I log on. In system settings the Guest used is still listed but is "Off". Screen Shot 2015-10-28 at 8.39.40 PM.jpg I think you need to make the change in find my mac and then go to "users" and turn off the Guest user.
 

maxsix

Suspended
Jun 28, 2015
3,102
3,683
Western Hemisphere
I turned it off and do not get a Guest user choice when I log on. In system settings the Guest used is still listed but is "Off".View attachment 596503 I think you need to make the change in find my mac and then go to "users" and turn off the Guest user.
You are correct. Although from my perspective I don't understand why it is, but I had this exact problem.

No matter how many times I deleted the guest account that I did not create... it returned upon restart.

Frankly I cannot remember what thought caused me to turn off find my mac other than I guess I was just unchecking everything to do with iCloud. After I unchecked find my mac, I deleted the guest account and it didn't return. All is fine now.

iCloud is a very buggy cloud anyway. And I don't mean just because of this but there's a quite a list of bugs.

I use Google Drive, Microsoft One Drive, Dropbox and Box. They are very reliable, without being buggy like iCloud.