Can't delete music from library?

Discussion in 'iOS 8' started by jdamiano, Jan 5, 2015.

  1. jdamiano macrumors member

    Joined:
    Sep 28, 2014
    Location:
    NJ
    #1
    On both my iPhone and iPad both running the latest version of iOS, I can't swipe to delete songs I don't listen to anymore. Can anyone help me out on a way to delete old songs? I don't have a Mac or PC to sync it to.
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2

    Settings > music > make sure "show all music" isn't on. If it is its showing songs from the cloud. You can't delete those
     
  3. xlr8or macrumors member

    Joined:
    Mar 9, 2013
    #3
    Same Problem

    I too have the same issue on a 16 GB iPad Air running iOS 8.1.3, which has little room for music due to the number of apps that I need to run.

    I've unchecked the Music > Show All Music slider and have also deleted (by swiping left) on all of the songs on my iPad [it's a pity you can't swipe left on albums to delete]. In iTunes, I have checked the box for Manually Manage Music and have gone in to the Music section on ITunes and unchecked the boxes on as many songs as I can.

    The problem is:
    1.) that not every song will allow me to uncheck it and,
    2.) everytime I sync my iPad to iTunes, it reloads most (but not all) of my songs back onto my device.

    Any suggestions or hints on Music removal? Thanks!
     
  4. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #4
    Same on iPhone 6 16gb.
    Well kinda.
    I've turned off Show all Music, and hidden iCloud music from my iPhone, but whenever I buy a song it just magically appears on my device! argh. I can delete songs though from it, just annoying that everytime I purchase a song it comes on my phone when I tell it not to!

    My iPod however doesn't do this. It's still JB on 8.1 though, my 6 is on 8.1.3. Could be a 8.1.3 issue?
     
  5. jamesdmc macrumors 6502

    Joined:
    Oct 17, 2007
    Location:
    Cittagazze
    #5
    This is on an iPhone 5C running 8.1.3.

    Swiping to the left to delete a track is insanely difficult. What I did...

    Step 1: Settings-->Music-->deselect "Show All Music", then deselect "iTunes Match"

    Step 2: Settings->General-->Usage-->Manage Storage-->Music-->Edit (upper right corner of the screen)

    Once you select "Edit", you should get delete buttons beside all the data in the app. In my case, it listed several audiobooks, each with its own delete button, followed by "Tracks" and it's delete button, followed by "Artists" and it's delete button. When I deleted the tracks, the artists disappeared too.

    See if that works for you.
     
  6. xlr8or macrumors member

    Joined:
    Mar 9, 2013
    #6
    Step 1 was already tried and didn't work.
    Step 2 doesn't show Music as one of the apps in the Settings->General-->Usage-->Manage Storage-->Music-->Edit (upper right corner of the screen) menu sequence.

    Any other suggestions? Thanks!
     
  7. Woochifer macrumors 6502a

    Joined:
    Apr 22, 2007
    #7
    Go into Airplane Mode and see which songs are physically on your device.

    Then redownload those songs from iCloud (assuming you purchased them on iTunes). Once you have them downloaded, then you should be able to manually delete them from the Manage Storage settings.

    Otherwise, if you're using iTunes, you should just uncheck the Sync Music box.
     

Share This Page