Can't delete object in Pages

Discussion in 'Mac Apps and Mac App Store' started by Vidd, Apr 7, 2008.

  1. Vidd macrumors 6502a

    Vidd

    Joined:
    Mar 7, 2006
    #1
    It can't be ungrouped, cut, moved, transformed or deleted.
    It can't even be changed from floating to inline.

    It's a bunch of shapes grouped together after having styles (shadows) applied to them. I opened up the file and now I can't move it.

    EDIT: Also, is there any way to stop objects mysteriously jumping to other pages rather than moving with the text?
     
  2. vandozza macrumors 6502a

    vandozza

    Joined:
    Jun 14, 2006
    Location:
    Australia
    #2
    did you lock the element in question?

    go to the "arrange" menu and check unlock and then try to delete again.
    (also shift-command-L will work.)
     
  3. Vidd thread starter macrumors 6502a

    Vidd

    Joined:
    Mar 7, 2006
    #3
    You are amazing, thank you!

    Now I have two more problems.

    1. How can I make something overlap a table? I thought I had done it before but it keeps inserting itself into the cells.

    2. The images fly about and will not simply move up and down with the text. They fly off into other random pages. Can I fix this? It's getting really annoying with this 100+ page document.


    EDIT: Got 1. fixed by getting it to float but I'm sure due to 2. that this will end up being a problem.
     
  4. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #4
    In the inspector you have the option to make objects float or move with text. This setting is in the menu with text wrapping.
     
  5. Vidd thread starter macrumors 6502a

    Vidd

    Joined:
    Mar 7, 2006
    #5
    Yes but my problem is that I need them to move with the text so that I can add pages before the diagrams. My problem is that the images shoot off into other pages rather than following the text properly.
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    They follow the text properly -- you just need to make sure they're anchored to the right place. Turn on "show invisibles" -- this helps. You will also notice, if you look carefully, that when you drag a graphic the insertion point in the text moves.
     

Share This Page