Can't Delete Older iCloud Backup: "This Backup Is Still In Use"

Discussion in 'iOS 7' started by JPM42, Apr 2, 2014.

  1. JPM42 macrumors 6502

    Joined:
    Oct 21, 2007
    #1
    A family member of mine recently upgraded their iPhone to an iPhone 5S (running iOS 7.1), and as I set it up and restored from a previous iCloud backup, everything went fine, until I decided to delete their old iCloud backup from the previous phone. Once I tried doing this, a message kept appearing, saying that the backup cannot be deleted, because it is still in use.

    Initially, I figured that perhaps the phone was still restoring, but 24 hours later, this prompt still appeared. Because of this, I decided to create a new backup for the 5S, and then I restored the phone again, but this time from the 5S backup. However, when I tried to delete the iCloud backup from the old phone, this prompt still appears.

    I'm unsure what's causing this and how to fix this, especially since having both of these backups leaves the user with very little iCloud backup space left.

    Any help is greatly appreciated. Thanks!
     
  2. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #2
    Have you tried a hard restart of the old device? Just hold the home and power buttons together until the phone restarts. Then give it a shot, it may help.
     
  3. aDRock1154 macrumors 65816

    aDRock1154

    Joined:
    Nov 15, 2011
    Location:
    Ohio
    #3
    I've had multiple replacements and I can say it takes roughly 2 days for the backup to be deleted. It's weird and I have no explanation as to why.
     

Share This Page