Can't Delete Trash

Discussion in 'macOS' started by brendajo, Jan 30, 2010.

  1. brendajo macrumors newbie

    Joined:
    May 8, 2008
    #1
    Can't delete the trash, says I don't have permissions?? Tried holding down option key with delete, no luck. Tried to drag items out of trash, they seem to stay in??

    Any suggestions. Have repaired permissions, still no luck.
     
  2. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #2
    Often a simple restart will fix things like this. Give it a try...
     
  3. Riverrun macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    ~
    #3
    If the restart doesn't work, open Terminal and type: sudo rm -R . Leave a space after the -R and drag the items in trash into the Terminal. Press "Enter."
    Type in your password, press enter again and volia.
     
  4. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    Just make sure the only things you drag to the Terminal window are things you want deleted.
     
  5. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #5
    If you are going to that trouble, why not cd into .Trash first to make sure nothing bad happens?
     
  6. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #6
    Did you try holding the Command key instead. this initiates the Secure Empty function of the Trash. Eg. Hold the Command key then right click the Trash icon in the Dock.
     
  7. hedfelt384 macrumors newbie

    hedfelt384

    Joined:
    May 12, 2009
    Location:
    Gold Coast Australia
    #7
    ------------------------------------------
    Greetings. I also made the big mistake (unknowingly) of trying to Time Machine folders and now have many folder sitting in my Trash. When I attempt to trash the trash it is taking me a million years to remove them so i stopped trying. I tried following the advice of using the Command key with the right side of the mouse. It firstly says "Secure Empty Trash" and when I try to follow the first instruction to "Remove Unlocked Items" which I click on. That which stays open for around 3 seconds then closes and that does not unlock anything. Then I tried the same dialog box again which gives me the choice to "Remove All Items", it then shows a dialog box showing 703 Items which stays open for around 3 seconds then closes. Nothing is unlocked or trashed at all. What on earth is happening?
     

Share This Page