Can't disable SIP from 2009 MacBook!

Discussion in 'MacBook' started by dandeco, May 6, 2017.

  1. dandeco macrumors regular

    Joined:
    Dec 5, 2008
    #1
    OK, as I mentioned, I have a mid-2009 polycarbonate MacBook, that I put a 256 GB solid state drive in and installed macOS Sierra on. But when I recently reset the PRAM, whenever the Mac boots up now, it shows the message that SIP has been enabled! I am unable to do certain things like change the brightness of my display. I try to boot into Recovery Mode to disable it, but I can't get into Terminal! The menu bar doesn't work at all, except the wi-fi icon. I think this is another thing SIP is causing, thus making it almost impossible to disable it in the first place!
    Can anyone give me any help on what to do here?
     
  2. gooser macrumors 6502a

    Joined:
    Jul 4, 2013
    #2
    sierra on a mid 2009? that may be your problem right there.
     
  3. ApolloBoy macrumors 6502a

    ApolloBoy

    Joined:
    Apr 16, 2015
    Location:
    San Jose, CA
    #3
    I'm surprised you got that far since the mid-2009 models only go up to El Capitan (officially anyway).
     
  4. dandeco thread starter macrumors regular

    Joined:
    Dec 5, 2008
    #4
    Well, I soon began having more problems; Bluetooth, USB, keyboard and trackpad wouldn't work among booting up! So I backed up all my data, wiped the drive and re-installed El Capitan and that fixed the issue.
     

Share This Page