Can't downgrade Iphone 3GS Firmware

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hsj2011, May 12, 2011.

  1. hsj2011 macrumors regular

    Joined:
    Jan 30, 2011
    #1
    I updated my iPhone 3GS to 4.3.3 yesterday and ever since, my phone seems much more sluggish than it has in the past. Things like typing in text boxes on the Internet have a slight delay, etc. So, I want to downgrade back to 4.2.1 (which is what it was on before).

    I have downloaded the 4.2.1 firmware off the Internet and I have changed the hosts file to include "74.208.10.249 gs.apple.com" but every time I try to do the update, I get an error saying "The Iphone could not be updated. An unkown error occured (3194).

    I have also tried to do this on the mrs' MBP but I get an error saying my iPhone isn't eligible.

    Has anyone got any ideas on how I can get round this please?
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Do you have SHSH blobs save for your phone? if not, you can't downgrade the firmware on your phone to 4.2.1 because Apple has stopped signing this 4.2.1 firmware.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Did you have saved your shsh blobs for version 4.2.1 before?
    If you're not sure download and run Tinyumbrella and click save shsh with your iphone plugged in.
    It will download and tell you what firmware version you can downgrade to.
    http://thefirmwareumbrella.blogspot.com/
     
  4. hsj2011 thread starter macrumors regular

    Joined:
    Jan 30, 2011
    #4
    Thanks, I just tried that and don't have any saved so out of luck by the look of it :(
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    It's possible something on your backup is mucking up the phone.
    If you can reload your contacts, etc. without your backup, try and see if your phone works better with a clean restore.
    In the future, start saving your blobs whenever a new iOS comes out. If I was going to give every iPhone owner advice, I'd tell them to back up at least once a week (syncing everyday) and save their blobs.
     

Share This Page