Can't download 4.1 from Apple...HELP!

Discussion in 'Jailbreaks and iOS Hacks' started by fuzion11, Oct 14, 2010.

  1. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #1
    I am trying to download the official iOS 4.1 from Apple.

    I already updated my phone to 4.1 using tiny umbrella and a 4.1 file from
    i-clarified, which preserved my baseband. I'm still having a ton of Bluetooth problems so I figured I'd update my baseband to what it is supposed to be at when on 4.1 to see if this helps with the Bluetooth issuses.

    When I try to download 4.1 from Apple it will give me an error message everytime saying my connection has timed out.

    In the past I've altered my host files to cydia...it's been so long that I forget what the default host file is supposed to look like. I erased the last line that I think is Sauriks server...Anyhow, I ran iTunes as administrator, resigned into iTunes again.

    I'm also wondering if I go into the phone via ifile and change the system files in the iPhone to make it think its on 4.0.1 then maybe I could download 4.1 (remember when imovie 1.1 came out and the only way 4.0.1 users could get it was to make the iPhone think it is on 4.1....well that but the opposite this time) maybe that would help??

    Any ideas or suggestions anyone? I would rather have a firmware on my phone that came straight from apple.

    Thanks in advance!
     
  2. Cap41 macrumors 6502

    Joined:
    Nov 19, 2008
    #3
    74.208.10.249 gs.apple.com get rid of this line. In fact gid rid of any line with a reference to gs.apple.com.

    THere is a tutorial on iClarified on how to edit your host file. Also after deleting or commenting out this line. You need to restart your computer.
     
  3. TB07-NJ macrumors 68020

    Joined:
    Jul 7, 2008
    Location:
    US of A
    #4
    Just try renaming hosts to something else and try the upgrade again but:

    This is the "default:" 127.0.0.1 gs.apple.com
    This is the TU change: 74.208.10.249 gs.apple.com
     
  4. fuzion11 thread starter macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #5
    Well I finally figured it out...

    I unchecked "allow simultaneous downloads" in iTunes

    And connected the network cable directly into my PC as opposed to through my router.

    I hope this helps someone else in the future.
     
  5. vachargerfan macrumors regular

    Joined:
    May 28, 2008
    #6

    Thanks. Worked perfectly for me..although I didn't need to reboot
     

Share This Page