Cant download any apps directly through my iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by luisluisbd, Aug 26, 2010.

  1. luisluisbd macrumors newbie

    Aug 26, 2010
    Every time I try to download something it says

    "Name of app goes here" will be available for download when you log into the itunes store on your computer.

    My phone is jailbroken, however it has been for almost a month and I never had this issue. Please let me know any info.

  2. celticpride678

    Feb 15, 2009
    Boston, MA
    Have you tried restarting the device? Syncing it up to the computer?
  3. luisluisbd thread starter macrumors newbie

    Aug 26, 2010

    I just did a normal phone restart and a full sync and still nothing.
  4. dnwild macrumors newbie

    Sep 8, 2011
    My daughter's phone has the same problem but mine doesn't

    My daughter's iphone 4 has the same problem. Her's was jailbroken but supposedly removed. My iphone 4 has not experienced this problem yet in over 6 months. My phone never jailbroken. Also,interested in a solution for this problem.
  5. dnwild macrumors newbie

    Sep 8, 2011
    Had my daughter turn off wi-fi on her iphone4 and use 3G to connect to App Store. It worked perfectly for about 6 apps. Now I am suspecting the router in her house.

Share This Page