Can't download any files at MBP

Discussion in 'macOS' started by iWolf00, Sep 11, 2010.

  1. iWolf00 macrumors member

    Joined:
    Jul 7, 2010
    #1
    Hi all,

    I can't download any software of file at my Mac OSX, I used Safari, Firefox & opera and still can't download the file. Each time I try to download the file I got black screen in Safari and nothing happen afterward. I tried to download the same file from different Mac and the download start immediately. do anyone have a solution to this problem;

    FYI, I have MBP 3.1 with snow leopard as operating system.

    Thanks in advance
     
  2. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #2
    Can you download any other files or is it no downloads at all from any site any time? What kind of file are you trying to download? Have you tried control clicking the file and selecting save file as?

    Have done the standard computer problem fixes such as cleaning out your cache files, internet cache, running the cron tasks and repairing permissions followed by a restart?

    Cheers
     
  3. charlieroberts macrumors 6502a

    charlieroberts

    Joined:
    Feb 5, 2007
    #3
    The same thing happens to me, I don't know why.

    What happens is that safari tries to "open" the file, instead of downloading it, ad because safari cant display the filetype, you get a black screen.

    I have not found a solution except command +click on the link instead of just click, to force download.

    I hope someone has a better idea!
     
  4. iWolf00 thread starter macrumors member

    Joined:
    Jul 7, 2010
    #4
    I've done all possible solution, but the problem persist. I've fully reinstall snow leopard and couldn't solve the problem.

    I believe we share the same issue, but you gave me an idea; by using Command + clicking on the link to force downloading the file. I shall use this method for now. Thanks for your input
     

Share This Page