Can't Download Apps After 3.0

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AlmostJosh, Jun 17, 2009.

  1. AlmostJosh macrumors 6502

    AlmostJosh

    Joined:
    Sep 13, 2008
    #1
    Whenever I try it acts like its going to start, then the new app icon disappears and it brings me back to the first home screen. Anyone else?
     
  2. mikelucas1 macrumors newbie

    Joined:
    Nov 7, 2007
    #2
    ive got something like this too, last app i downloaded has a darkened icon and says waiting and has been like that for 30 minutes
     
  3. Narzist macrumors member

    Joined:
    Jun 16, 2009
    Location:
    Germany
    #3
    I had the same problem here.
    But now it works again.
     
  4. iLoveMyApple macrumors 6502a

    iLoveMyApple

    Joined:
    Oct 26, 2008
    Location:
    California
    #4
    Me toooo! It says Waiting... and then goes away and brings me to the home screen and say "Cannot download app"
     
  5. mfillhart macrumors member

    Joined:
    Apr 4, 2009
    #5
    mine did that till i accepted the new terms & conditions by signing in
     
  6. AZR macrumors newbie

    Joined:
    Jun 17, 2009
    #6
    I'm having the same problem, but I believe its due to Apple software distributions servers being overloaded with the 3.0 update. (I'm having the same problem with Itunes on my desktop machine.)

    It appears that its hung up trying to retrieve the new 'terms and conditions' and that once you approve those, it will work again as normal.
     
  7. UserName macrumors member

    Joined:
    Feb 11, 2004
    #7
    The App Store is Being Hammered

    I think the hang problem with the App Downloads for iPhone is due to the sheer weight of traffic due to the OS update
     
  8. gerfuls macrumors member

    Joined:
    Jan 31, 2009
    #8
    I tried accepting the terms and conditions on my mac in iTunes, then rebooted my iPhone and I'm having the same issue still. Are there terms I have to accept on the phone itself?
     

Share This Page