Can't download apps on iPad

Discussion in 'iPad Tips, Help and Troubleshooting' started by acastic, Apr 20, 2012.

  1. acastic macrumors regular

    Joined:
    Jan 6, 2004
    #1
    For some reason, I can't download apps to my iPad (3rd gen), even though I was able to download 3 apps without issue yesterday. I can browse the app store, surf the web, etc, but when I go to download an app, it just says "waiting" by the app and never actually does anything until it times out with an error message saying that it can't download the selected app, please try again later. I've tried different apps, soft resetting the iPad, turning wifi off/on, and connecting to a different wifi network, but no luck. I have an iPhone 4S as well andit has no problems downloading apps. I am completely confused. Any ideas?
     
  2. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #2
    I experienced a similar problem for a very short time today so I just waited for an hour and tried again and no more problem.
     
  3. Getitdone macrumors member

    Joined:
    Jan 24, 2012
    #3
    There are problems updating apps, purchasing apps, etc. across different devices right now - discussions ongoing on Apple Support Communities.
     
  4. Barney US macrumors newbie

    Joined:
    Sep 4, 2012
    #4
    Problem downloading apps

    I had a problem downloading apps. Went on for a couple of days and said waiting when I tried. Finally started deleating most recent apps I had downloaded. It only took about two and downloading started working fine. Don't know what it was unless something was hung up. Hope it helps some of you.
     

Share This Page