Can't Download Apps on iPod Touch.

Discussion in 'iOS Apps' started by .michael, Jul 12, 2008.

  1. .michael macrumors regular

    Nov 7, 2007
    So, I downloaded the 2.0 software, and when I try to download apps from the store off my touch, I get the message that tells me to sign in iTunes, and when I connect my iPod to my computer I can download it (something similar to that). What do I do? I already signed in, and it still gives me the same message when I try to download an app from the Touch. :confused:

    Unable to Download Application :

    ______________ will be avaliable for download when you log in the iTunes Store on your computer.

    (actual message)
  2. alexkay macrumors newbie

    Jul 13, 2008
    Same Here ... Sorta ...???

    I'm pretty pissed. I was soo excited to try out 2.0. When I got the download and tried to download some free apps to try it out. It showed it downloading and then said,

    "Unable to Download application
    ApplicationName will be available for download when you log in to the iTunes Store on your computer."​

    So i connected to my computer where I was already logged on and always am and basically nothing happened and I unplugged my iPod from computer and looked and the app(s) were then working. I'm confused and frustrated would appreciate HELP. Thanx
  3. shnigutsu macrumors newbie

    Aug 4, 2008
    :confused: I can not download apps or updates for apps with my ipod touch. it makes me angry that it happens. Someone please help me and the person before me.
  4. superstrikertwo macrumors 65816


    Jun 9, 2008
    Are you downloading from the iPod touch section in the app store? Not sure if that makes a difference.
  5. Mal macrumors 603


    Jan 6, 2002
    You have to go to the Store menu in iTunes and click "Check for Purchases".

    You could have found that very quickly if you'd searched, too.

  6. alexkay macrumors newbie

    Jul 13, 2008
    yea ... ?

    Yea, I actually did get that pretty quick forgot to mention, but the thing is that i can't download apps straight from the app store to my Touch which is frustrating when you don't have access to the comp (or to lazy to turn comp on and plug in) at times. I just wanna be able to use apps download and use on Touch right away.
  7. Night Spring macrumors G5

    Night Spring

    Jul 17, 2008
    Are you sure your wifi connection is good? Recently, when I tried to download an app from my Touch, I got a similar message. I noticed that I only had one bar on my wifi connection. I moved to where I had a stronger connection and tried again, and presto, the app downloaded.
  8. liliajams macrumors newbie

    Jul 23, 2008
    Updates not working thru iphone or itunes

    When I have an update available, and I click on the Update money, the update starts but then stops with same message: Unable to Download, will be available for download in iTunes store. When I sign in to iTunes, it tells me there are no updates available for my account. When I click on Check for Purchases, same thing.

    I thought it might work once I synced, but then I get the message that the application was not installed on the iphone because an unknown error occurred 0xE800002E.

    Now I did find, that if I deleted the application thru iPhone and then reinstalled, the updated application was loaded. However, this doesn't save my stuff that was already in the application, so it's like starting over. Which, as you can imagine, is very frustrating.

    I've considered resetting the phone, but won't this erase all the information I have on it, like my contacts, todo lists, etc.?
  9. zenguyme macrumors newbie

    Aug 20, 2008
    Problem Solved - For Me

    I too had this same problem for the past two weeks and was pulling my hair out {what is left}.

    How I fixed it, on your iPhone go to .......

    Settings ---> Safari ---> Accept Cookies ---> (select) Always

    I had "Never" selected under this option and now all is well in my world. Except I am back to buying applications as an impulse.;)
  10. yacitus macrumors newbie

    Aug 26, 2008
    Deleting apps from iPhone and then adding them back worked for me

    I got the 0xE800002E error after downloading updates for four apps for my iPhone.

    I went into the Applications tab in "iPhone" in iTunes and unchecked them. (I already had the "Selected applications" radio button selected.) I then pressed the Apply button to sync and delete them from my iPhone. Then I re-enabled them (in the Applications tab) and pressed Apply to sync them back to my phone. I didn't get the error.
  11. And5555 macrumors member

    Jun 16, 2008
    I have this same problem on my iphone. I just got the 2.1 update hoping that would fix it, but nope. It happens for me every time I try to update or install any app no matter how big it is.

    I tried googling and didn't find much. My cookies are enabled and I tried the doouble tap trick.

    The only thing that I can think of is the fact that I had it jailbroken at one point (though about a month ago) and have since restored. The only thing I can think of is maybe the partion size I chose when I jailbroke wasn't good.

    Other people having this problem, have you jailbroken before?

    Anybody have any other ideas?
  12. jvik macrumors newbie

    Aug 31, 2009
    I'm having the same problem. I've litterally tried everything that should help and I've never done a jailbreak on the phone.

    Well. Hey guys. Problems was solved by putting in a new sim card from same carrier.

Share This Page