Can't download from App Store, stuck on "Waiting"

Discussion in 'iOS 5 and earlier' started by MoodyM, Mar 17, 2012.

  1. MoodyM macrumors 6502a


    Aug 14, 2008
    I can't seem to download anything from the App Store on my 5.0.1 iPad 2. Every one I try gets stuck on "Waiting". I've tried leaving it 12 hours+, no luck.

    I tried signing in with both mine and my girlfriend's AppleID, same problem. I tried turning Automatic Downloads on and off, both ways, no luck.

    If I download from the iTunes Store on my computer, then sync, they go onto the iPad just fine.

    I've tried rebooting, hard reset, etc, etc.
  2. OlgaJ macrumors 6502

    Mar 27, 2009
    Some apps will not download unless you have the most recent update of the OS. Try downloading one app at a time to see if you get a pop up message.
  3. dwlms3 macrumors newbie

    Mar 22, 2012
    Same issue

    I was unable to take updates or dowmlaod from the App store. The app would appear and get stuck at the "Waiting...". I updated the iOS to the latest and still the issue persists. Have taken the same steps as OlgaJ by rebooting, but that does not work either. Any ideas on if this is fixable or a new issue that Apple will need to fix?
  4. TheAppleSource macrumors regular


    Mar 9, 2012
    United Kingdom
    Few questions first:

    When one of the attempts gets stuck on "Waiting" are you able to hold down on the icon and then click the cross to remove it?

    If you go into the app store and find the stuck install, are you able to click install again?

    If you tap on the icon, does it say "Paused"?
  5. roll2puff macrumors newbie

    Mar 23, 2012
    Sofia, Bulgaria
    I had the same issue, ever since the phone detected the 5.1 update.
    I'm jailbroken on 5.0.1 and don't want to update for now.
    I solved the problem by resetting all settings, it's a hassle to set everything up again, but it fixed the bug.
  6. toasty hoodie macrumors 6502

    toasty hoodie

    Sep 16, 2011
    Happened to my grandma's ipad 1. I had to do an iCloud backup and a reset all settings to get it to work. Took about 10 mins
  7. jloafer macrumors newbie

    Sep 19, 2012
    I can't download form the App Store on my iPhone 5. It was working great when I got it but then Sunday night it just said waiting and never loaded. I talked with apple support and they had me do everything possible other than restoring the phone. Any suggestions?
  8. MaGeLaNi macrumors newbie

    Dec 10, 2012
    Apps waiting / apps warten


    I had the same after upgrading to my new iPhone5. All apps were on status waiting after restore a backup to the new phone.

    You simply have to synchronize with your iTunes and you'll now receive the data as with the restore it only seems to restore metadata information such as the name of the app, musictrack etc.
  9. alcinoandre macrumors newbie

    Jun 8, 2011
    Here is the solution for that:

    "The solution or fix seems to be to remove a file “downloads.28.sqlitedb” from a folder on the device. There is an app called iExplorer (formally iPhone Explorer) that allows you to see your devices folder structure without having to Jailbreak the device.

    Locate the folder “Media”, open it and locate the folder “Downloads” and open it. Inside the folder “Downloads” you will see several folders with what appears to be random numbers (I had well over 50) as well as a file called “downloads.28.sqlitedb”.

    (If you Jailbroke your device you can use iFile to delete that file.)

    All you have to do is delete “downloads.28.sqlitedb” file and then restart the device."

    It worked for me and that messages "waiting" below the grey icons disappeared.
  10. lighterrr macrumors newbie

    May 17, 2011
    This worked for me, initially I cant download my app using wifi (only works on 3g), thanks a lot.

  11. UltraX7 macrumors newbie

    Apr 29, 2013
    Only a few minutes ago I finally figured this out with the aid of another article I managed to dig up. But I still face a problem I cannot find a solution for ANYWHERE and am hoping to find one here; even after ridding my device of those damn frozen waiting bars, I can't update any of my apps without it resulting in the app becoming stuck again. I can purchase and download new apps without any problems, but just not update any of them.
  12. sumanrox macrumors newbie

    Apr 29, 2013

    About my opinion it is your network problem. You need to fix your network problem now.
  13. Dleragha macrumors newbie

    Dec 8, 2013
    Same issue

    Hi bro
    I have same issue, nothing remains to solve this issue I have not do, as well as deleting the file mentioned above.

Share This Page