Can't download from download links

Discussion in 'Mac Basics and Help' started by gslrider, Mar 30, 2011.

  1. gslrider macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #1
    Not sure when this started happening, but I've noticed it for the last few months now. Whenever I click on download links like Firefox, Epson, Apple, Adobe, etc... it just hangs. My browser tells me it's transferring data, but it just stays there like that. No download happens. However, if click on download links say from sites like Filesonic, links download just fine. Also, sites that have a direct link (as in when you roll over the download link, it tells you the path way to a .dmg file, not a php page that auto connects you to the file), I can do a right click and do a "save link as", that works fine. But if it's the auto connect, like Firefox and Adobe site, I can't do that method. I thought maybe it might be my connection online, but when I go on my brother's Mac, he is able to download instantly from the links I can't. I'm pretty sure something in my system is doing this. But what it is, I have no idea. The last time this happened to me, I full system wipe and reinstall of Mac OS X 10.5 and all my apps was the only way it was fixed. Now it's happening again.

    Has anyone ran into this issue? Or does anyone know what is causing this on my system? What preference or extension?

    Thanks.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What browser do you use and have you tried resetting it via the Menu Bar > Browser Name >> Reset?
     
  3. gslrider thread starter macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #3
    I use primarily Firefox, but it does the same thing with Safari. Both are the latest versions. I think it may have to do with javascript. I turned javascript off on Firefox. Relaunched it, so now instead having the download button for Mac OS X, I got three links Windows, Linux and Mac OS X. From there I was able to right click on the Mac OS X link and do the save link as technique, and was able to download. Turned javascript back on, and back to not being able to download automatically.

    I've done the browser reset, the download reset, the download dir reset. I've also done several permission repairs. Which I'm curious, if the first permission repair repaired certain permissions, why did the same permissions pop up on the second permission repair and third. It's like it never really repaired anything, or it did and the system almost immediately reverted back to how it was before the repair. I've even used Spring Cleaning to search for damaged, and orphaned files. Deleted those. As well as did a system cache clean. But none of those things worked.

    I'm almost certain now it's a file that's conflicting with browser download using javascript. I just have no clue what file or files that is.
     
  4. cwik macrumors newbie

    Joined:
    Aug 12, 2008
    Location:
    city of Angels...
    #4
    Same problem-please help!!

    i have the same problem...i cant download anything from site links! sometime i can right click and get it to donwload, but not everytime.

    have NO idea what the problem is...

    like you i repaired permissions, and it did the EXACT same thing...it says it repaired them but then the same problems keep popping up like it never repaired anything.

    i dont know what to do and i NEED TO DOWNLOAD THINGS!!

    please help....im about to freak out...

    thanks
    cwik
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    What browser do you use and what exact Mac and Mac OS X version do you have?
    Have you tried another browser? Can you provide a link example (website with links)?
    Does it also happen in another, even temporarily created, user account?
     
  6. cwik macrumors newbie

    Joined:
    Aug 12, 2008
    Location:
    city of Angels...
    #6
    its SAFARI!!

    yes ive tried opera/chrome and its only happening in SAFARI.....sigh

    there obv a conflict somewhere but i have no idea which one. it really started out of the blue too....

    any ideas? i donwloaded 5.1.7 for snow leopard, installed it, and the same thing keeps happening.

    please...i really like safari the best and have used it primarily for years...any help on how to fix this problem would be soooo appreciated!!

    much thanks...
    cwick
     
  7. gslrider thread starter macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #7
    After Firefox came out with two more updates, I no longer have this issue. Even on Safari and Chrome. Guess it was a Firefox thing. Still can't explain why it happened, or why the Firefox updates seem to have corrected the issue within Firefox and Chrome as well. I'm just glad I don't have this problem anymore.
     
  8. cwik macrumors newbie

    Joined:
    Aug 12, 2008
    Location:
    city of Angels...
    #8
    just installed lion and safari's still doing it..sigh

    i dont understand....im only having a problem with safari...i can download normally with other browsers.

    were u havn the same issue but with firefox/chrome?

    i have no idea what i may have/what was installed thats causing this. almost anytime now that i want to download something i have to use any other browser OTHER THAN SAFARI...

    i also just installed LION and now have safari 6 and its STILL not downloading when i click on various download links on various sites...

    SOOOOO FRUSTRATING!!!!

    any other/more help on what i can do to fix it/find the extension or app thats causing this would be GREATLY APPRECIATED...

    much thanks every1....honestly..sigh
    cwick

    ----------

    yes ive done that...ive done everything i can think of...(btw im not a noob...been a machead for yrs)

    anyways...id appreciate anything else u can think of...please!

    thanks...
    cwik
     
  9. gslrider thread starter macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #9
    cwik: I was having that issue with Firefox, Safari and Chrome. Not all the time and not all sites. Only certain sites, most times. I stopped going to those sites and have updated Firefox three times since. I have recently went to those sites with download issues, and no problems. I'm not sure what has happened in the last year or so. I have done nothing different other than update the browsers to the latest ones. And I haven't had any of my previous download issues. The only other thing I can think of is for you to delete Safari and all it's extensions, and preferences, then reinstall.
    Code:
    http://www.macupdate.com/download/40516/Safari5.1.7SnowLeopard.dmg
    It's older, but see if that works. If it fixes, then do an update, and see if the problem comes back. Sorry I can't be of anymore help.
     
  10. cwik, Aug 14, 2012
    Last edited: Aug 14, 2012

    cwik macrumors newbie

    Joined:
    Aug 12, 2008
    Location:
    city of Angels...
    #10
    reply...

    thanks all to hell man...appreciate the effort.

    i had 5.1.7 installed b4 and it of course still did it...im gonna use appzapper and delete safari, then with a fine tooth comb delete anything else that needs deleting, then do the re-install using the link you sent me.

    if it still does it after that ill try going back to 6 (not expecting any difference), and then most likely just pick a new browser to start using...(unreal...)

    newaz-thanks for the help...really do appreciate it
    cwick

    (OR...i can still use safari and just use 'develop' to load the page in another browser when i need to d.load something...a pain yes, but itd work...sigh)
     

Share This Page