Can't download L4D2 on steam macbook pro

Discussion in 'Mac and PC Games' started by squidsta, Jun 25, 2011.

  1. squidsta macrumors newbie

    Joined:
    Jun 25, 2011
    #1
    Hello everyone,

    Today on my steam account I bought L4D2 for 20 dollars on my macbook pro. At first it was downloading very slow. It then said suspended for about 10 minutes so I restarted steam. And now, in the "All Games" section of my library it continuously says "Left 4 Dead 2 - Starting Download...", however it never actually starts. To get it downloading I have tried the following things:

    -Restarting steam
    -Leaving it for a few hours then coming back to it
    -Renaming the "clientregistry.blob"
    -Deleting the "clientregistry.blob"
    -Clicked on "Delete local game content"
    -Changing the "download region" (several times)
    -Restarting my computer
    -Double clicking on "Left 4 Dead 2". When I do this it says "validating files". Then "files successfully validated". Then it says "steam servers are currently too busy to handle your request, please try again in a few minutes" When if that the case why have i waited far more than a few minutes? And I can download anything else. The only thing that won't download is Left 4 Dead 2.

    PLEASE give me some suggestions. There is no way for me to personally contact steam through email or a phone call. I don't want my 20 dollars to have gone to a complete waste because of steam errors. I could really do with help from someone.

    Thanks a lot!
     
  2. a.jfred macrumors 6502

    Joined:
    May 28, 2010
    Location:
    Austin, TX
    #2
    I had this issue last week - and I'd downloaded & installed L4D & L4D2 in October/November 2010 (I'd last played in Nov 2010).

    I wish I could remember exactly which directories I had to navigate to, but you want to look for the .blob and the .ncf files that go with L4D2. Rename the .blob file to Old<whatever-it's-called>.blob (this way, you have a copy of the original, should it ever be needed), and then delete all the .ncf files. Restart Steam, and try your download again.

    I *think* it's Library/Application Data/Steam/Left for Dead 2, but I'm stuck at work, and won't be home or another 2 hours. I'll check when I get home.

    ETA: Sorry ... I just saw in your post where you'd edited the .blob file. Try removing the .ncf files. I ended up having to rename the .blob _and_ delete the .ncf before it worked.
     
  3. a.jfred macrumors 6502

    Joined:
    May 28, 2010
    Location:
    Austin, TX
    #3
    Okay here's exactly what I did:

    1) deleted L4D2 off the computer. Then I attempted to download it again, but kept getting "servers too busy."

    2) Quit Steam

    3) (home)/Library/Application Support/Steam --> renamed ClientRegistry.blob to 'oldClientRegistry.blob'

    4) (home)/Library/Application Support/Steam/SteamApps

    5) removed ALL L4D2 .ncf files (I'm showing 3 total files). This included emptying the recycle bin

    6) Restart Steam & the download.

    Since I did that, I've had no problems with the game.
     
  4. Astra92 macrumors newbie

    Joined:
    Jun 21, 2011
    #4
    I'm having this same issue, but I'm using Lion and can't seem to find the Steam folder under Application Support. Anyone?
     
  5. The.Walrus macrumors member

    Joined:
    Apr 18, 2010
    #5
    On Lion, you'll need to go to the System/Library not User/Library. To do this, you'll need to go to Finder, hold down the option button, and from the "Go" menu, select "Library."

    You can then navigate to System/Library/Application Support/Steam/SteamApps to find your downloaded apps.

    Hope this helps.

    Paul
     
  6. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #6
    Sorry about the issues, kind of surprised there isnt that much talk about this one on the Mac. Its allways a good thing to see those Mac versions of popular games. Very happy Steam made this one for us.
     
  7. JonasDK, Dec 1, 2011
    Last edited: Dec 1, 2011

    JonasDK macrumors member

    Joined:
    Aug 18, 2011
    Location:
    Denmark
    #7
    Finally

    I had the same issue. It would not download do to "busy server" etc.

    I tried following the guide above, but it did not work.

    What I did was, I just kept clicking the game - when I got the "busy server" I just kept pressing the game.

    In the "steamapps"-folder I could see that more and more files appeared as I pressed the game (the .ncf files etc.)

    Suddenly it started downloading - but during the download it stopped a lot of times, however finally the game was downloaded, and everything works fine now.

    I don't know if the above makes any sense, but that was what I did, and it worked.
     

Share This Page