Can't download large files

Discussion in 'Mac Basics and Help' started by joane, Jul 6, 2011.

  1. joane macrumors newbie

    Joined:
    Jul 6, 2011
    #1
    I have a late 2009 IMAC which is running 10.6.3. I am trying to upgrade to 10.6.6 to get the app store, but when I download from the download site, the download speed slows down to a crawl (2 kb/sec). The time remaining increases to multiple days, then the download fails.
    I have been searching various forums and tried lots of things -
    - connected via ethernet instead of airport. This allowed to download files up to 10 MB.
    - checked download speed - my supposed high-speed dsl is about 1.51 mbps. This is the same on my work laptop (running windows 7), and on my daughter's MBP. But I was able to download the large update at a steady rate of about 90 kbs.
    - changed location name in network preferences.
    - deleted cache, reset safari.
    - downloaded Mozilla and tried that.

    I can download the files to my work laptop, but don't have any way to get the files from the laptop to the imac. the laptop is a work computer, so it has a lot of restrictions built in.

    Calls to applecare have not been that helpful, but I was able to download a 144 MB update from the download site, but the next one I tried did not work.

    My most recent call to applecare resulted in the suggestion that I bring the computer in for a genius appointment. I have spent so much time on this already, and carrying the computer into a mall will not be easy for me. Any other suggestions? I saw a suggestion for Applejack.
    Thanks!
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Try deleting the following files from the ~/Library/Preferences/ directory:

    com.apple.internetconfig.plist
    com.apple.internetconfigpriv.plist
    com.apple.internetconnect.plist
     
  3. joane thread starter macrumors newbie

    Joined:
    Jul 6, 2011
    #3
    Thanks. I only had one of these files, which I put in the trash, then stopped and started the IMAC.
    Still having the issue. It's interesting that the first .7 MB go fast, then it slows down. Then if I pause, and start again I get another .7 MB. I could try doing this for an hour (feeling like Desmond in Lost) or two, but I wonder if the file would mount after all that.
    There must be something interfering with the download that was not running the one time I got a normal download, but have no idea what this could be.
     
  4. joane thread starter macrumors newbie

    Joined:
    Jul 6, 2011
    #4
    re: pausing and restarting - I got about 12 MB before the download failed and set me back to 2 MB.
     
  5. joane thread starter macrumors newbie

    Joined:
    Jul 6, 2011
    #5
    I tried my daughter's laptop - she has the same problem, so this may be a router iissue, in case anyone else is having a similar problem. May nned to have Verizon update the firmware in the router.
     

Share This Page