Can't download on iPhone, can on Mac

Discussion in 'Mac Basics and Help' started by vmachiel, May 13, 2012.

  1. vmachiel macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #1
    Hi forum,

    Weird problem: I can't download anything from the iTunes store or app store directly to my iPhone. Podcast for example won't start downloading (stuck on "wating") and apps appears with the "waiting" underneath it, only to disappears again with the message saying: can't connect to iTunes store.

    But, it all works fine on my mac, anyone got any ideas as to why this is?

    Thanks
     
  2. ezramoore macrumors 6502a

    Joined:
    Mar 20, 2006
    Location:
    Washington State
    #2
    Have you rebooted the phone? Does it happen on 3G AND WiFi or just 3G? Have you tried multiple wifi hotspots?
     
  3. vmachiel thread starter macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #3
    Happens on both 3G and Wifi, even after reboot. Didn't try any hotspots, just my home router
     
  4. vmachiel thread starter macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #4
    Ok, today I've tried a different router and it worked. Still no luck on my home router even after rebooting the thing. Anything i can do in the router settings that you know off?
     
  5. JohnRocks macrumors member

    Joined:
    Dec 2, 2010
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    Which router? Manufacturer, model, revision, etc.
     
  7. ezramoore macrumors 6502a

    Joined:
    Mar 20, 2006
    Location:
    Washington State
    #7
    I would take the tack of actually resetting the router and then setting it back up.

    If it is your gateway/modem for DSL make sure you know your PPoE or PPoA password before you reset it.
     
  8. vmachiel thread starter macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #8

    Probably not the router after all, saw the exact same problem on the iOS part of the forum, linking it to the 5.1.1 update. Thanks for the help all.
     

Share This Page