Can't Download or Update: Error 100 in Mac Appstore

Discussion in 'Mac Apps and Mac App Store' started by SteelBlueTJ, Jul 12, 2012.

  1. SteelBlueTJ macrumors 6502

    Joined:
    Apr 2, 2012
    Location:
    USA
    #1
    I am having 2 problems since I switched from a 2007 iMac to a new Mac Pro. First, I installed an SSD as a boot drive and reinstalled Lion then used Migration assistant to copy my files from my old mac to my new mac pro. I also have a 1TB drive in bay 2 for files and media. Apps and OS are on SSD. Now when I click on an app the I originally downloaded from the App store I get a pop up message saying, "“App” was purchased using App Store on another computer. To install “App” on this computer, sign in using the Apple ID and password used to purchase it." I enter the info and nothing happens.

    Second, when I open the App store and try to update an App, I get this message, "There was an error in the App Store. Please try again later. (100)"
    I have tried everything I could think of to get this corrected short of reinstalling the OS and starting from scratch. Deleted the appstore cache file, restarting, downloading a free app in iTunes, etc. Does anybody have any indication of what's going on or how I can fix it without having to start over? Thanks.
     
  2. Anonymouse106 macrumors newbie

    Joined:
    Jul 5, 2012
    #2
    Same thing here, got a new rMBP yesterday and the app store just gives me Error 100 and Error 13. I tried the fixes found online but none worked.
     
  3. Pipper99 macrumors 68000

    Pipper99

    Joined:
    Aug 14, 2010
    Location:
    Fort Worth, TX
    #3
    I just got a new retina MBP, and I can't download the updates for iMovie or iPhoto. I'm getting a similar message saying that the apps were purchased under another Apple ID, but I don't have another Apple ID. I am, however, able to download my other purchased apps.

    The message is, "You have updates available for other accounts. To update this application, sign in to the account you used to purchase it."
     
  4. Anonymouse106 macrumors newbie

    Joined:
    Jul 5, 2012
    #4
    I fixed my problem. The folder ~/library/cookies permissions were set to read-only. Changed them to read-write.

    I had done this to prevent Safari from saving cookies, back when it had a bug that would save them even if you selected "never" in preferences, and I just forgot to change it back.
     
  5. fredsarran macrumors 6502

    fredsarran

    Joined:
    Jun 15, 2008
    #5
    That did not help me, But I am only getting a error 100 message.
     
  6. PantherJeep macrumors member

    PantherJeep

    Joined:
    Jun 24, 2010
    Location:
    Oceanside, CA
    #6
    For whatever it's worth, I just encountered the error 100 issue updating a couple apps, and resetting the permissions on ~/library/cookies to Read & Write (and applying it to enclosed items) fixed it. Not the most secure thing ever, but it at least let me update my apps. :cool:
     

Share This Page