Can't Drag and Drop Anything in iTunes

Discussion in 'macOS' started by yeah3x, Jul 15, 2015.

  1. yeah3x macrumors member

    Joined:
    Sep 22, 2014
    #1
    Hi, my iTunes worked fine on my 2013 Macbook Air for about 18 months. Since the fall of 2014, I can't drag and drop anything. If I click and hold, nothing happens. Everything else works fine and this has been happening across all version of iTunes since. I can't figure how to reinstall since it is linked to OSX (correct?). This is a major annoyance for making playlists and adding songs to my phone. My trackpad works fine dragging and dropping files and I have tried using a mouse. I have also rebooted my system since then obviously. Any help would be greatly appreciated!
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    you can delete iTunes.app from the Terminal, then download it from here : https://www.apple.com/itunes/download/
     
  3. yeah3x, Jul 16, 2015
    Last edited: Jul 16, 2015

    yeah3x thread starter macrumors member

    Joined:
    Sep 22, 2014
    #3
    Ok so I still can't drag and drop anything after a fresh install. Is there anything that could be causing this? I also can't drag anything in the dock to rearrange any icons if that mans anything.
     
  4. yeah3x thread starter macrumors member

    Joined:
    Sep 22, 2014
    #4
    Solved the issue! Seems PushBullet was messing it up. Deleting it solved all my problems!
     

Share This Page