Can't eject disk from external CD/DVD Drive on Mac Mini with ML

Discussion in 'Mac mini' started by msarro, May 10, 2013.

  1. msarro macrumors newbie

    Joined:
    Apr 25, 2013
    #1
    Hey everyone, the title is pretty verbose. I have 3 different macbooks around, and all 3 have no issue having disks inserted/ejected with the external drive.

    However the moment I attach it to the mac mini, it'll gladly accept the disk. But when you try to eject the disk, it will unmount, but that's it. The drive motor doesn't stop, it won't eject period. I've tried ejecting from disk utility with no luck. I've tried ejecting from within itunes and DVD player. No response from any except for DVD Player which gave an error "-47." Which, you know, is super helpful :confused:.

    I've also tried connecting the drive to a USB2 hub which was connected to the mac mini, with no change (not that I'd expect a lot).

    When I disconnect the drive (with disk in it) and connect it to any of the other macs (all running lion) they eject with no issue. I can re-insert with any other mac and then re-eject, no issue. It is only an issue on the mini.

    So the only differences I can see are
    1) The mac mini is running mountain lion while the MBPs are running Lion
    2) The mac mini is a mac mini, and everything else is a MBP
    3) The mac mini has USB3 ports, where the other devices have USB 2 ports.

    Any thoughts??
    I am using this guy:
    http://eshop.macsales.com/item/Other+World+Computing/VLSS9TOPTU2/

    The drive is from my personal macbookpro.
     
  2. msarro thread starter macrumors newbie

    Joined:
    Apr 25, 2013
    #2
    Figured out what was happening - I had XBMC running in the background, and it monitors for the presence of a disk. When I attempted to eject through XBMC, it ejected. Likewise, when I exited all XBMC processes, the normal system eject functionality worked as expected
     

Share This Page