Can't eject Time Machine external HDD?

Discussion in 'OS X El Capitan (10.11)' started by virginblue4, Mar 6, 2016.

  1. virginblue4 macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
    #1
    I've have created an encrypted time machine backup and now wish to eject it and store somewhere safe. I plan to do a backup every weekend as the MacBook will be out with me during the week.

    However, when I try to eject, I just keep getting this message? Even though it is not actually being used. Any ideas?

    Edit: I can't upload the file. Macrumors keeps saying there was a problem.
     
  2. CoastalOR, Mar 6, 2016
    Last edited: Mar 6, 2016

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    Try restarting the the Mac with the drive attached then a eject should work (El Capitan has an issue with releasing a drive sometimes)
    or
    Shutdown the Mac then disconnect the drive.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Is the message something like it can't be ejected because the drive is in use? If so, try going to System Prefs and add that drive to the Spotlight exclude list. That can happen when Spotlight is continuously trying to index a partition on an external drive.
     
  4. virginblue4 thread starter macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
    #4
    I turned the computer off and ejected it, but I'll try your suggestion next time. Thank you :)

    Out of interest, does anyone know why I can't upload screenshots? I never usually have any problems.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Image uploads are working for me. Just drag and drop the image into the white space below your text in the compose window. Do you maybe have Javascript turned off in the browser or an adblocker running that is breaking things.

    Test image.

    Screen Shot 2016-03-06 at 10.11.06 AM.png
     

Share This Page