Can't empty a Trash

Discussion in 'macOS' started by steinramm, Mar 10, 2009.

  1. steinramm macrumors member

    Joined:
    Aug 16, 2007
    #1
    I have one file deleted but when I try to empty, it says:

    "The operation can't be completed because the item is in use."

    I have set all permissions of that file to Read & Write but still can't empty.

    I also tried to rename file, move to another folder etc, but without success.
     
  2. MotleyPete macrumors regular

    Joined:
    Jun 9, 2008
    Location:
    Blighty
    #2
    Hold down the option key and try emptying it

    If that doesn't work, restart, then empty the trash.

    [​IMG]

    "Have you tried turning it off and on again?"
     
  3. steinramm thread starter macrumors member

    Joined:
    Aug 16, 2007
  4. Ploki macrumors 68020

    Joined:
    Jan 21, 2008
    #4
    what about through terminal with superuser acc
     
  5. steinramm thread starter macrumors member

    Joined:
    Aug 16, 2007
  6. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #6
    Open Applications -> Utilities -> Terminal

    Before trying to remove it from the command line, you might be able to release the file from whatever's holding it. To see what application is keeping it type (replace <filename> by the name of the file):
    Code:
    lsof | grep <filename>
    That's lower case LSOF | GREP ...

    If it returns the name of a recognizable application, try closing the app down. I'd do this rather than removing the file immediately since some apps recreate files they can no longer find.

    Then you should be able to remove the file either normally from Finder, or by typing:
    Code:
     rm ~/.Trash/*
    Of course, even this might not work ... I was trying to help someone here yesterday with the same problem, but no matter what we suggested, he couldn't delete the file from his Trash.
     
  7. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens
    #7
    I once had a similar problem solved installing the dashboard widget 'trash'
    you can download it here
     
  8. Oneiromancer macrumors newbie

    Joined:
    Aug 24, 2009
    #8
    This is an old thread, but when Googling "the operation can't be completed because the item is in use", which according to Google Instant many people do, this is the second result, so many people are still viewing it without finding any definite answer.

    For anyone else having this problem:

    Just had the same problem and solved it. The terminal returned no application except finder, but that's the point. It turns that if there's no other application running, the file is in use by the finder. So, relaunch the finder: command, alt, escape.
     
  9. snypa macrumors newbie

    Joined:
    May 10, 2011
    #9
    Relaunch the Finder - Brilliant!

    I could hug you. This worked brilliantly for me. It was so simple I couldn't believe it. Thanks so much!
     

Share This Page