Can't empty my trash :(

Discussion in 'MacBook Pro' started by saraegan, Dec 27, 2010.

  1. saraegan macrumors newbie

    Joined:
    Dec 27, 2010
    #1
    Hello, So I've only owned my MBP for about 2 months now, my first mac, and I'm still pretty new at everything so I'm not sure if I'm just missing something or doing something wrong but this is my problem.

    So I have the file "sixtyforce" stuck in my trash can. It says it is still in use, but as far as I know it isn't at all. I've tried restarting, shutting down for a while and turning it back on, forcing empty and it's still there. So I googled this problem and I found http://www.lancelhoff.com/cant-empty-trash-on-a-mac/ with a solution, But after I follow the directions, open terminal, enter the code, drag "sixtyforce" from my desktop and press enter, it gives me the warning then it says Password: and I CAN'T TYPE ANYTHING :( AT ALL. I tried it like 20 times.

    So I closed terminal, restarted the mac, opened terminal again to try it and now nothing happens AT ALL when I type in cd ~/.Trash && sudo rm -rf , add the files and press enter. Nothing.

    This is really frustrating and I can't find any other options to get rid of these files, and the apple support help nothing worked for me in there either. Any help???
     
  2. millerb7, Dec 27, 2010
    Last edited: Dec 27, 2010

    millerb7 macrumors 6502a

    Joined:
    Jun 9, 2010
    #2
    Have you tried:

    "sudo rm -r "

    Without the quotes obviously... but NOTE THE SPACE after -r. Then, take the file from the trash can and drag and drop it in terminal. It will auto populate the source of the file for you, then hit enter. Type your PW and enter again....

    That work at all? It has never failed me at removing anything. I use it to remove HUGE files all the time since trash takes to long... I'm talking 50GB+ files... it takes a fraction of the time.

    As far as the password, IT IS TYPING EVEN THOUGH YOU CANNOT SEE IT! It never shows when you type in your pw. Just type it in properly following case-sensitivity and hit enter.. you will then see the line refresh.
     
  3. saraegan thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #4
    I just tried sudo rm -r instead and nothing happened.. I mean it's just sitting there like I didn't press enter at all :( Which sucks because before it was at least doing something, and now that you say the password won't show up to type it anyway, that crossed my mind so i tried and it just repopped up password. I did three times until it stopped me. Unless I don't know what password it's talking about? So I feel like I screwed something up since terminal isn't doing a thing anymore..
     
  4. saraegan thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #5
    And GGJStudios when I said nothing worked for me in the apple support I was talking about that page, sorry.
     
  5. rmbrown09 macrumors 6502a

    rmbrown09

    Joined:
    Jan 25, 2010
    #6
    I have sixty force installed, never tried to remove it though. In your activity monitor see if something related to that is running? (That you can tell)
     

Share This Page