Can't empty recycle bin

Discussion in 'macOS' started by bpetruzzo, Jan 17, 2010.

  1. bpetruzzo macrumors regular

    Joined:
    Oct 22, 2005
    #1
    I have an application in my recycle bin that won't go away! It is insisting that it's in use. I've tried restarting my computer a couple times and have had no success.

    Is there some way to tell what's using a particular file or something? Or perhaps some way to force the recycle bin to empty? It's really getting annoying.
     
  2. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
    You can try typing this in the terminal...

    sudo rm -rf ~/.Trash/*

    Woof, Woof - Dawg [​IMG]
     
  3. Gene Shalit macrumors newbie

    Joined:
    Nov 29, 2009
    #3
    Re: Can't empty recycle bin

    I had this exact same problem about a week ago. Here's how I fixed it:
    -Take the application out of the trash
    -View the package content
    -Move all the files out of the application and into the trash
    -Move the empty application into the trash
    -Empty the trash; this should delete most of the files and the empty application
    -Take the file(s) that can't be deleted back out of the trash
    -Use TextEdit to open the file(s)
    -Select everything and delete it, leaving the file(s) blank
    -Save and overwrite the file(s)
    -Put the file(s) back in the trash
    -Empty the trash
     
  4. bpetruzzo thread starter macrumors regular

    Joined:
    Oct 22, 2005
    #4
    Thanks for the responses guys. I tried the command line option first and it worked perfectly.

    Thank you for taking the time to respond!
     

Share This Page