Can't empty the trash or install an update on ibook


macrumors 68020
Original poster
May 24, 2007
i'm having a few problems with my ibook g4 running leopard.

yesterday i installed a number of apple updates most of which had been available for a few weeks. the iphoto update could not be installed. and when i then tried to open iphoto, it would not open.

i put in the trash and re-installed iphoto from the ilife08 disc. iphoto has opened fine since but i am unable to delete the old iphoto (or at least what's left of it as it's 516KB) from the trash and get a message saying "finder cannot complete the operation because some data in 'huEN41wJTpbl6L' could not be read or written (error code -36)". i have tried unsuccessfully to force the trash to empty by using the option key and various methods from this site:

a few weeks ago i was also unable to install the office 2004 update getting the message "the installer could not locate the correct version of the software to install the update". so that's two updates i have had problems with.

i have repaired permissions and do not know what to do next. any suggestion will be gratefully received.


UPDATE: i have been into disk utility again and noticed that "repair disk" is greyed out but have attempted to run "verify disk" which failed saying:

invalid sibling link
volume check failed
error: filesystem verify or repair failed.


Sep 7, 2008
forlod bygningen
A little bit strange.

I have a G4 iBook too, and the hard drive started to show its age at the end of least year with clicking noises.
I used this to find out if there's a problem. The drive had a SMART failure coming, but it was not manifesting like your's.

Now it works like a charm and the clicking noise comes only once in a month or so.

Btw, the software I linked to is no repair application, only a monitor software.


macrumors newbie
Oct 2, 2008
did you resolve this, i got the same problem !!
i also reformated my mac and i still got the trash with those things grrr

im very upset

i write zeros 7 times to the hard disk and nothing.

what i can do>