Can't empty trash because of permissions?

Discussion in 'Mac Basics and Help' started by th3g1z, Apr 14, 2010.

  1. th3g1z macrumors newbie

    Joined:
    Apr 3, 2008
    #1
    I have had this folder in my Trash for quite some time now and every time I go to empty my Trash I get the following error:

    The operation can’t be completed because you don’t have permission to access some of the items.

    I'm not certain why that appears, I have tried to securely empty trash and still no such luck. I searched around a bit but nothing seemed to help me complete this simple task. Its just a folder with a few subfolders in it and in total is not any space.. just empty folders Size says 0kb.

    Any ideas?
    Thanks
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Open /Applications/Utilities/Terminal.app and copy and paste the following text into the Terminal window.

    sudo rm -rf /.Trashes/* /Users/*/.Trash/*

    (Typing the text rather than copying is a bad idea because a misplaced space can cause it to erase every file on your hard drive.)
     

Share This Page