Can't empty trash "OS X in use"

Discussion in 'macOS Sierra (10.12)' started by Fzang, Sep 26, 2016.

Thread Status:
Not open for further replies.
  1. Fzang, Sep 26, 2016
    Last edited: Sep 26, 2016

    Fzang macrumors 65816

    Fzang

    Joined:
    Jun 15, 2013
    #1
    EDIT: Ended up wiping the partition and doing a new backup. Not the prettiest solution, but nothing to lose in my case.

    I once deleted an old Time Machine backup by throwing it to the trash. Now, every time I connect my external drive with a Time Machine partition and a separate file storage partition, I see a ton of files I can't delete. Finder says they're located at

    /Volumes/Time Machine/.Trashes/502/Backups.backupdb.

    They're quite problematic since if I want to empty trash (which I do quite frequently, as I have a high turnover of large files) it first has to spend 10-15 minutes shuffling through about 130,000 files, after which it says "can't empty trash because SomeSystemFile is in use".

    I've tried first aiding my external drive partitions.
    I've tried Apple's recommended chflags -R nouchg
    I've tried rm -f

    None of them work.
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    sounds like a perfect solution; it got you back in business, what matters most. :cool:
     
Thread Status:
Not open for further replies.

Share This Page