can't empty trash

Discussion in 'Mac Apps and Mac App Store' started by shanner, Dec 10, 2004.

  1. shanner macrumors member

    Jul 21, 2004
    I put a downloaded file in the trash but can't empty the trash because the file is locked and i can't get it out now because apparently i don't have sufficient priviliges?!?!
    any ideas?
  2. Sparky's macrumors 6502a


    Feb 11, 2004
    Hold the "Option" Key when you select "Empty Trash" in the menu bar.

    If that doesn't work then see the latest issue of "MacAddict" they have a terminal command that will absolutely empty the trash.

    If I had it here at work I'd copy it here for you, or if you want I'll post when I get home.

    Good Luck
  3. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    If you search this forum, you'll find a bunch of threads on this same topic.
  4. jxyama macrumors 68040


    Apr 3, 2003
    rm -rf .Trashes/*

    in terminal will empty trash most of the time...

    make sure it's really trash, because you won't get a second chance...

    and, sorry, but it's a pet peeve of mine. why do people bother posting "just search" without offering the results - it's not very helpful? if you want them to search, why not just ignore the thread instead?

    if you search "empty trash", you get one thread that's relevant out of 25 listed in the first page. and it's 23rd out of 25, posted 2 months ago.
  5. hikeNM macrumors 6502a

    Sep 29, 2004
    Somewhere close to a dairy in East Texas
  6. Sparky's macrumors 6502a


    Feb 11, 2004
    I agree. I've asked questions before that even after I tried a search nothing comes up and then some says "why don't you just search for it , there have been many Threads on that......"

    Anyway here's what MacAdict say on the subject. (and I'm trying to reprint this directly from the Jan 2005 issue.

    In the terminal

    [rmyslewski:~]rmyslews% sudo rm -ri ~/.Trash/*

    I guess rmyslewski is the user name but the accompanying caption to the sample says "If emptying the Trash results in stubborn resistance, employ the Terminal and force the job using this command"
  7. shanner thread starter macrumors member

    Jul 21, 2004
    i tried all those things and still no luck.
    - I can't use onyx because i'm just on 10.1.5, but I tried something from version tracker called 'force empty trash', which unfortunately didn't work.
    - In terminal it asked me if I wanted to get rid of the things and then said ' opperation not permitted'. (! ?)
    During my efforts i've also gotten a message a couple of times which looks weird saying "I assume you've gotten the usual lecture from system administrators and it boils down to two things. 1)respect the privacy of others and 2) think before you type"
    That sounds malicious.
    What have i done?

    by the way - I don't know why I didn't think of searching the forum originally - sorry about that.
  8. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    First of all, check your Trash and make sure you know what everything is. You don't want to erase a system file or something.

    Second, reboot your computer and try to empty the trash.

    If you still can't empty it, open the terminal.
    Type: sudo rm -rf ~./Trash/*

    Here is what this stuff means (if you don't know)
    sudo = basically enhancing your privledges
    rm = remove command
    -r = recursive flag to handle folders
    -f = force flag to handle permission problems
    ~/.Trash/* = means go to the Trash folder and select all files

    You may get a message and a request to enter you password, don't worry about what it says and just enter your password.

    Hope this works.
  9. shanner thread starter macrumors member

    Jul 21, 2004
  10. JSully217 macrumors newbie

    Dec 11, 2010
    Help too

    I have the same problem but it all of the commands arent working, the trash is still there. Is there something i have to do to make it empty after that?

Share This Page