Can't enable iMessage, FaceTime Not Working, iphone 4, iOS 5

Discussion in 'iOS 5 and earlier' started by tido2012, Oct 16, 2011.

  1. tido2012 macrumors regular

    Jul 20, 2010
    So here is my problem. I have posted on a couple of other people's messages but I cant seem to find a solution. I am trying to do this on an iphone 4, with iOS 5, never been jailbroken, FaceTime used to work on iOS 4.3.

    Basic problem:
    I can not enable iMessage under settings--> messages-- iMessage. I flip it over to enable it and i can switch it from off to on. As soon as i eventually get back to the home screen or if I enable multitasking and click over to the message app and get come back to this screen the phone has iMessage -off. I have called the apple support and I didn't get anywhere with them. I was advised to take the phone in (seems like this has happened to one other person).

    Facetime Issue:
    Under settings, phone, there is no facetime settings. Also, there is no facetime setting anywhere else that I can find it. FaceTime used to work with the previous 4.3 software, for some reason it doesn't seem to be working now.

    What I've done to try and fix this:
    Hard reset.
    Delete iCloud and redo it.
    Turned off and on- not sure why I even did this.

    What I'm about to try:
    Reinstall iOS5.

    Why I'm killing time doing this:
    I cant believe I cant get iMessage to work on an iphone 4 when it works perfectly fine on my iphone 4s. Also, if anyone else has this problem, hopefully it will help them too without having to go into the store, doesn't seem to be a common problem. I'll be back to update after re-installing iOS 5 and keep others posted as to whether that works or not.
  2. tido2012 thread starter macrumors regular

    Jul 20, 2010
    What I did and it's results:
    So i erased all content and settings under (general settings, reset , erase all content and settings) on the iPhone 4 and it's going and installing all the apps right now but I have tested the iMessage and it works. I have not tested FaceTime but there is a section under settings just like my iphone 4s. This is not my iphone 4 but I had gotten a little bit into this thing after I got annoyed when I wasn't able to fix it.

    What I did that makes me believe to have caused these problems:
    I think that I may know what my problem was, I installed iOS 5 on an iPad 1 and logged into it with the same email as the one that I had logged into for the iphone 4, which is why i deleted the iCloud settings on the iPad 1 before going into general- settings- reset- erase all content and settings on iphone 4.

    Ok this will probably be the most I ever type on a single thread but hopefully if this is annoying the crap out of anyone else it will fix their solution. It may be a rare problem because I was the smart one that installed iOS 5 on my friend's iPad 1 before installing it with the same email on her iPhone 4 :eek: Goodnight!
  3. klrobinson999 macrumors 6502

    Dec 28, 2008
    I haven't had your particular problems, but have faced my own with GMail refusing to load, and text messages not displaying the character count (even though the option was enabled). Luckily all I had to do was change the password for GMail and a hard reset for the text messaging.

    iOS5 has created some strange - and quite varied - results.
  4. tido2012 thread starter macrumors regular

    Jul 20, 2010
    I feel really smart but I actually think my problem could have been solved a lot faster. I went to settings- general - restrictions and I had turned camera off there because I thought that it would restrict people from changing that. The reason doesn't make sense now but when I was trying to restrict people from changing location to "don't allow changes" so that find my iphone could be used in case the phone was ever stolen. I haven't had problems with gmail this time around although I have encountered problems with it in the past. Oh well, so far I love this new operating system, just gotta get the kinks worked out. It's amazing what a hard reset will do sometimes, if only I could do that on myself after getting off work at times. :D

  5. cmvog macrumors newbie

    Oct 18, 2011
    I had this problem too, where initially imessage worked, and then I mucked around in settings and suddenly imessages kept turning off. I realised I'd disabled facetime in the restrictions section of settings. Once I enabled facetime, imessages remains on and is working.

    hope this helps
  6. atm2 macrumors newbie

    Dec 6, 2011
    thank you!

    Right! It's all in the "Restrictions"! Thank you for solving a major headache.
  7. Robyn314 macrumors newbie

    Mar 3, 2012
    iMessage now works across all devices.

    It's all about the restrictions! I disabled all of them on iPhone 4 and iPad 2 and now it works perfectly.
  8. Aniro macrumors newbie

    Jun 8, 2011
    Character count doesn't show until the second line of the message

Share This Page