Can't enter password in Terminal! Aargh!

iChief

macrumors member
Original poster
Jun 19, 2004
77
0
Bankside, London SE1
I am trying to uninstall Virex 7.5. I have got the Terminal uninstall command which opens Terminal. So far, so good. However, Terminal is asking me for my admin password but it's not allowing me to enter it. The cursor is not blinking it's just a solid black oblong - just bl**dy sitting there! Absolutely no response to any key except the enter key - then terminal helpfully says, 'Sorry, try again' What's going on? I just wanna get rid of Virex!!! :mad:

Can anyone help, please? My iBook is working perfectly apart from this one annoyance. I'm using OS 10.3.9. Thanks.
 

iindigo

macrumors 6502a
Jul 22, 2002
719
10
San Francisco, CA
iChief said:
I am trying to uninstall Virex 7.5. I have got the Terminal uninstall command which opens Terminal. So far, so good. However, Terminal is asking me for my admin password but it's not allowing me to enter it. The cursor is not blinking it's just a solid black oblong - just bl**dy sitting there! Absolutely no response to any key except the enter key - then terminal helpfully says, 'Sorry, try again' What's going on? I just wanna get rid of Virex!!! :mad:

Can anyone help, please? My iBook is working perfectly apart from this one annoyance. I'm using OS 10.3.9. Thanks.
Ahh yes I see where this is confusing - you see, the Terminal doesn't show *any* feedback of any type when you type in your password - Meaning that it will still look like this no matter what:

Password:

Don't worry, this is normal - just type it in anyway and hit enter. That should work...
 

iChief

macrumors member
Original poster
Jun 19, 2004
77
0
Bankside, London SE1
iindigo said:
Ahh yes I see where this is confusing - you see, the Terminal doesn't show *any* feedback of any type when you type in your password - Meaning that it will still look like this no matter what:

Password:

Don't worry, this is normal - just type it in anyway and hit enter. That should work...
Thanks so much, iindigo. You are a life saver!!! You can tell I'm a Unix virgin because I didn't know what was going on. :eek: I thought I was going crazy! :rolleyes: Every other help site just kept repeating the fact that I should enter my password. Thanks again for the clear & concise instructions. :D
 

blackshadow1998

macrumors newbie
Aug 10, 2010
9
0
Shanghai, China
Dude omg thx

I was also having lots of trouble with this, as i like to use one line commands that include "sudo"

since this required a password, your answer was extremely useful to me

2 thumbs up to u man!
 

Psychosmurf

macrumors newbie
May 13, 2011
1
0
I have the same problem

I try and type my password in Terminal, and saw nothing, but having read this thread i soldiered on however, even though i know I am inputting the correct password all i get is a message over and over saying "Sorry, try again".... this is getting really annoying as I cannot find any way to fix it

Many thanks

Willz
 

bpaluzzi

macrumors 6502a
Sep 2, 2010
919
1
London
I try and type my password in Terminal, and saw nothing, but having read this thread i soldiered on however, even though i know I am inputting the correct password all i get is a message over and over saying "Sorry, try again".... this is getting really annoying as I cannot find any way to fix it

Many thanks

Willz
What user are you trying to authenticate as? The terminal root user is not the same as a machine administrator.
 

RyanMacm

macrumors member
Feb 15, 2012
77
0
i accidentally copy and pasted "sudo tmutil disable local" onto my terminal now whenever i place my password it says: "command not found" what do i do?
 

Nikh

macrumors regular
Jun 15, 2010
182
3
Kyiv
i accidentally copy and pasted "sudo tmutil disable local" onto my terminal now whenever i place my password it says: "command not found" what do i do?
tmutil controls Time Machine, it doesn't do anything with passwords or so.
 

Nikh

macrumors regular
Jun 15, 2010
182
3
Kyiv
It depends on your needs, this command disable Time Machine local backups. If you need them - enable them back.