Can't erase my hard drive

Discussion in 'macOS' started by cfhjag, Sep 3, 2015.

  1. cfhjag macrumors member

    Joined:
    Jun 19, 2012
    #1
    Ok, so I did the most stupid thing ever. For some reason I though I could beat the battery time while installing an update on my Macbook Pro to 10.10.5 or so. Of course, computer died with just 5% left of the installation and I'm pretty angry with myself. Just a bit.

    So, I've tried starting the computer in recovery mode, to repair, verify permissions and all of that with no success. I've tried erasing the hard drive to install Yosemite all over again, no success. I tried to reinstall Yosemite straight from the recover menu, also with no success.

    I've now started my new macbook pro through my old one (target mode), just to access the drives in disk utility but still the same thing.

    Could anyone please help?
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    1. Take the bad drive OUT OF the MBPro.

    2. Get either a USB3 enclosure, or a USB3/SATA docking station, or a USB3/SATA adapter "dongle".

    3. Put the BAD drive into the USB3 enclosure or dock, and then connect the BAD drive to the OLD MacBook. Re-initialize the drive using Disk Utility.

    4. Install a working OS onto the drive. Doesn't matter -which- OS, so long as it will boot (capable of booting the MBPro, that is).

    5. TEST the drive BEFORE you put it back into the MBPro. Connect via USB, reboot holding down the option key and KEEP HOLDING IT DOWN until startup manager appears. Select the docked drive and hit return.
    DO YOU GET A GOOD BOOT?

    6. If you do, NOW re-open the MBPro and put the restored drive back in. With the back on, try to boot now.
    Any better?
     
  3. MJWMac1988 macrumors member

    MJWMac1988

    Joined:
    Aug 25, 2015
    Location:
    Western Nebraska
    #3
    Based on the way you worded that sentence, I would like to assume that you were successful in getting your new MacBook Pro's hard drive to appear (via target-disk mode) on the desktop of your old hard drive; but I can't be entirely sure how successful you were beyond that. I didn't know about the following before researching it in order to write this reply, and you probably already know it, but I'll mention it anyway: With newer USB-only Macs (if that's what you have), you have to use a specific type of USB cable to make target-disk mode work (properly?). Click here to get the details. If you already know all about this, then I don't know what else to suggest, at least not without more information.
     

Share This Page