Can't Erase or Repair Hard Drive

Discussion in 'Mac Basics and Help' started by un1ty, Nov 8, 2007.

  1. un1ty macrumors member

    Joined:
    Jul 9, 2007
    #1
    Silly me, I tried using an old hard drive as an airdisk with Time Machine. AirDisk has always been unstable with me but it was worth a shot. Time Machine actually worked with it once, but when I tried again it didn't work and it messed my hard drive up.

    So I connected my hard drive via firewire. I ran DiskWarrior and halfway through got a kernel panic. Now, Disk Utility sees the hard drive but won't mount it, repair it, or erase it (it hangs the whole system). Disk Warrior also just hangs the system when trying to rebuild it. I even tried Drive Genius and it also gets stuck trying to repair it or shred it. When I try to verify it with Drive Genius I get "Invalid catalog btree depth information (4,1)."

    Any ideas on how to force erase a hard drive? Maybe running it by a huge magnet? Sigh...
     
  2. computerman-8 macrumors member

    Joined:
    Oct 11, 2007
    #2
    I had a similar problem where the disk wouldn't have a partition and wouldn't erase. For me the disk utility in Leopard isn't erasing properly and had to take the Tiger DVD to erase the HD.
     

Share This Page