Can'T Execute Terminal Scripts by Double-Click (Mouse/Trackpad)

Discussion in 'OS X El Capitan (10.11)' started by migadrenaline, Mar 19, 2017.

  1. migadrenaline, Mar 19, 2017
    Last edited: Mar 19, 2017

    migadrenaline macrumors newbie

    Joined:
    Mar 19, 2017
    #1
    (the title is self explanatory - found nothing that solved this - I'm not a newb so the "regular" solutions don't work that's why a new thread)


    PS - ...Terminal app DOES INDEED execute (Slthough without opening any window) when double-clicking an already executable shortcut (or thescript itself - so it i not a problem with shortcuts) - but the "script" itself doesn't and since it is already configured to be executable doesn't even show it's path when terminal window opens as it would in other situations!

    PS2 - (of course) when exectuing normaly (prompt$ ./executable_script ) it works as always did - it only a double-click with trackpad/mouse problem



    .......Double clicking on the dock shortcut for these scripts I've made WAS INDEED Always OK and working perfecly
    .....I use them so often that I will consider formatting the system if I can't make them work since it's really not praticle (fast) to exectute them "normaly" in terminal without being able to double-click!
     
  2. chabig macrumors 601

    Joined:
    Sep 6, 2002
    #2
  3. migadrenaline, Mar 19, 2017
    Last edited: Mar 19, 2017

    migadrenaline thread starter macrumors newbie

    Joined:
    Mar 19, 2017
    #3
    NOTHing yet! - actually I never before have added the *.command extention and it worked - but knowing that now I've added it and the same happens! (and yes - of course I've done it exectutable)

    once again (I THINK) THIS IS IMPORTANT as it states that what "we want" is properly configured:

    ....... IF Terminal is a already open, as I double-click on a script Terminal becomes to be the active program and foreground window (this is a good indication that MAcOSX knows and has permission for the script to be executed and tried to exectute it as wel)... but but afterwords nothing happens, just the prompt and cursor blinking and nothing else!

    ........if terminal was closed as I double click an exectubale script, terminal "application" starts - but no window opens... I really think that for those who know Unix well this is a good indication of what is happening - although not my area :\
     

Share This Page