Can't find my Macbook hard drive/won't boot.

Discussion in 'MacBook' started by greason01, Jul 5, 2010.

  1. greason01 macrumors newbie

    Joined:
    Jul 5, 2010
    #1
    Hi everyone,
    I'm having a problem with my three year old Dual Core Macbook. I can't seem to get it to boot properly.

    I don't know if it's coincidence but i had recently downloaded some updates from Apple including an iTunes update. I had just accepted the iTunes agreement when the Macbook stopped responding to any input from me. I had to shut down using the power button.

    As i powered back up, the status light flashed a few times and then heard a loud beeping sound. After looking for help online, i removed each memory module individually, reset the PRAM all to no avail. I tried rebooting/reinstalling from the macbook software disk 1 but when asked which volume i'd like to install OSX on, the hard drive didn't show so could go no further.

    Would be grateful of any advice from you guys:)
     
  2. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #2
    Turn it on again, and listen to the pattern of the beeps.

    If it goes:
    BEEP, BEEP, BEEP, (pause), BEEP, BEEP, BEEP, (pause), … etc …
    , then your Mac thinks there's a problem with its memory (RAM). This is separate from your hard drive.

    If it's not a regular beeping sound, and it doesn't follow any pattern, it may be something different.

    Let us know what it's doing.
     
  3. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #3
    Thanks for your reply fluffyx.

    I've restarted a few times now, i'm not getting the bleeps anymore. I get the usual Apple startup music and then a whitish/grey screen. I can run disk utility from the OSX install disc. I've just run 'First Aid' and have got the error message

    'First Aid Failed

    Disk utility stopped repairing "disk0s2" because the following error was encountered:

    Filesystem verify or repair failed.

    The OSX install disc won't run either as it's saying that i can't install V10.5 as V10.4 or later cannot be found on my computer.

    Could this be a software/hard drive problem?

    Also getting a flashing question mark on folder picture sometimes
     
  4. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #4
    It's very*possible that your hard drive has failed.

    Even with the most severe software errors, the partition would usually show a friendly name rather than a block device name ("Macintosh HD" instead of "disk0s2").

    Your symptom whereby the computer froze in the middle of use also seems to suggest a failed hard drive.

    Do you have a backup of any important data? If not, you have a few options:

    • Use some "file rescuing" utility like Data Rescue or DiskWarrior to try and copy your files. Be warned, if you hear nasty sounds from your computer (clicking, beeping) during this process, turn off the power immediately!
    • If these file rescuing tools can't help, pursue professional data recovery.

    If you DO have a backup, try erasing your hard drive with Disk Utility. If the erase fails, you need a new hard drive.

    Write back and let us know how it goes.
     
  5. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #5
    Hi fluffyx, thanks for the reply. I've just installed a replacement hard drive - one recommended by my local Apple shop - and i am getting the same problem, the drive not showing in the options when choosing destination to install software.



    :(
     
  6. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #6
    That's frustrating, but normal. New drives are usually not formatted, so you need to format it. Fortunately, this is easy to do.

    While booted from the install disc, go to the Utilities menu at the top of the screen and choose Disk Utility.

    In the column on the left, you should see your new drive. Click on it.

    In the main part of the window, you will see a few tabs. Click on the Erase tab.

    Give the drive a name (like Macintosh HD) and erase it.

    Quit Disk Utility, then try to install Mac OS X. It should go smoothly :).

    I hope this helps!
     
  7. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #7
    Hi again, thanks for the quick reply:)

    I tried that earlier on but it was only showing the actual installation DVD only and not the new drive:confused:



    Gary
     
  8. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #8
    Oh no!

    Well, the hard drive isn't installed properly, or it is defective. Based on your description, it sounds like the rest of the computer is fine.

    The silver and white "sheath" that covers the hard drive's circuit board is mandatory, not optional. Did you transfer this sheath from the old drive to the new one? If it's not installed, the MacBook's frame will short out the circuit board.

    Get a Torx T8 screwdriver and transfer the sheath from the old drive to the new one. The screws to remove the sheath are on the sides of the drive, not the top!

    Or, if you did transfer the sheath, try removing and reinstalling the drive, and try again. Can you hear the drive spin when you turn on the computer?
     
  9. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #9
    Funny you should say that because the drive doesn't seem to be seated very well in the drive compartment. I guess i'll have to take the lower cover of the macbook off to check the contacts are aligned properly?

    :)
     
  10. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #10
    It's rarely necessary to remove the case in order to install a hard drive properly, but you're welcome to try.

    Can you try removing and replacing the hard drive first? Does the drive wiggle from side to side? back and forth?

    Please confirm whether you can hear the drive spinning, and whether you transferred the sheath, before taking your Mac's case off :).
     
  11. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #11
    I've removed and replaced the drive but isn't starting up at all, only sounds are the cd rom spinning momentarily and then the Apple startup music clip. I've used the cradle too. Is it possible that the pins that the hard drive plugs into are damaged?
     
  12. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #12
    Hmm, that's no good.

    Try putting the old drive back in (with the "cradle" installed) and see if you can hear it spin up. If neither drive spins up, it sounds like the drive isn't connecting properly.

    If your MacBook is, in fact, three years old, it qualifies for a hard drive repair extension program whereby Apple will replace your drive free of charge. (They keep your failed drive.) Perhaps they'd also be kind enough to see what's preventing the drive from being connected properly.
     
  13. greason01 thread starter macrumors newbie

    Joined:
    Jul 5, 2010
    #13
    Hi fluffyx, thanks for all your assistance:)

    I bit the bullet and removed the case from the macbook - i figured that something must have been physically stopping the hard drive from seating properly - and found that one of the rubber strips inside the hard drive compartment had become dislodged and was getting in the way of the connections. Everything seems to be working fine now.:D

    Interesting about the bad batch of macbook drives, it seems mine fits the description of the age/model affected. Sods law:rolleyes:

    once again, thanks for you help.

    Gary
     

Share This Page